Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » Papyrus » Java 8 support for Papyrus?(java 8)
Java 8 support for Papyrus? [message #1708710] Sat, 19 September 2015 06:22 Go to next message
Richard Freggi is currently offline Richard FreggiFriend
Messages: 110
Registered: July 2015
Senior Member
Hello, my Company prohibits use of Java 7 due to security risk, we can only use Java 8. I'm using a temporary kludge by editing the Eclipse ini file. Any idea when Papyrus will truly support Java 8?
Re: Java 8 support for Papyrus? [message #1708714 is a reply to message #1708710] Sat, 19 September 2015 08:30 Go to previous messageGo to next message
Ed Willink is currently offline Ed WillinkFriend
Messages: 6595
Registered: July 2009
Senior Member
Hi

What do you mean by truly support? What kludge do you need?

I use Papyrus with Java 8 and no kludges.

Regards

Ed Willink


On 19/09/2015 07:22, Ri Fr wrote:
> Hello, my Company prohibits use of Java 7 due to security risk, we can
> only use Java 8. I'm using a temporary kludge by editing the Eclipse
> ini file. Any idea when Papyrus will truly support Java 8?
Re: Java 8 support for Papyrus? [message #1708718 is a reply to message #1708710] Sat, 19 September 2015 09:37 Go to previous messageGo to next message
Richard Freggi is currently offline Richard FreggiFriend
Messages: 110
Registered: July 2015
Senior Member
I had to change this line in eclipse.ini

-Dosgi.requiredJavaVersion=1.7

to

-Dosgi.requiredJavaVersion=1.8

to install Eclipse, then install papyrus on top of it
Re: Java 8 support for Papyrus? [message #1708785 is a reply to message #1708718] Mon, 21 September 2015 08:31 Go to previous message
Camille Letavernier is currently offline Camille LetavernierFriend
Messages: 920
Registered: February 2011
Senior Member
Hi,

The Osgi RequiredJavaVersion only specifies a minimum execution environment. So having requiredJV = 1.7 and using Java 8 should just work.

Papyrus Luna requires at least Java 6, Papyrus Mars requires at least Java 7, and Papyrus Neon (June 2016) will require at least Java 8. But Papyrus Luna already works fine with a Java 8 JRE. A lot of Eclipse runtime plug-ins are still compatible with Java 1.4, and you don't need a Java 1.4 VM to use them

Regards,
Camille


Camille Letavernier
Previous Topic:Is there a maven repository somewhere to build Papyrus-based applications?
Next Topic:Need help with Nat Tables, can't show the Classifier type
Goto Forum:
  


Current Time: Sat Feb 29 05:00:20 GMT 2020

Powered by FUDForum. Page generated in 0.03749 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top