Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » Papyrus » OSGI Framework Bundle Exception(org.apache.batik.util [1.6 and <1.7] for papyrus 1.1 and eclipse mars (4.5) it should be 1.7)
OSGI Framework Bundle Exception [message #1707907] Thu, 10 September 2015 12:21
Sargunan r is currently offline Sargunan rFriend
Messages: 1
Registered: September 2015
Junior Member
Hello ,

I have created the product file with papyrus and eclipse mars plugins to create RCP, when I have launched my product i have got following error, (But works fine in launch configuration with all plugin config)

org.osgi.framework.BundleException: Could not resolve module: org.eclipse.papyrus.uml.perspective [526]
............................
Unresolved requirement: Require-Bundle: org.apache.batik.util; bundle-version="[1.6.0,1.7.0)"


I think problem is due plugin "org.apache.batik.css' with two different version required in my product file. "org.apache.batik.css ="1.7.0" is required for "org.eclipse.e4.ui.css.core" . But for papyrus plug-in it is excepting plug-in version 1.6.** .

Could anyone please help me how to solve this dependency problem ?


Eclipse Version: Mars Release (4.5.0)
Build id: 20150621-1200

Papyrus : 1.1.0






Previous Topic:New Alf Functionality Release Date
Next Topic:Interface realisation
Goto Forum:
  


Current Time: Fri Jul 10 06:53:07 GMT 2020

Powered by FUDForum. Page generated in 0.01768 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top