Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Error won't go away.
icon4.gif  Error won't go away. [message #1707582] Mon, 07 September 2015 15:27 Go to next message
Roberts Ruskuls is currently offline Roberts RuskulsFriend
Messages: 2
Registered: September 2015
Junior Member
Hi, I am getting the [the markup in the document following the root element must be well-formed] error, and I can't find how to fix it. I am developing an icon pack for Holo Launcher based on this: http://forum(dot)xda-developers(dot)com/showthread.php?t=2399426 . Here's the code for three xml's that I am getting the errors in (They're not done yet):

Appfilter.xml

<?xml version="1.0" encoding="UTF-8"?>
<resources>
    <iconback img1="iconback" />
	<iconmask img1="iconmask" />
    <iconupon img1="iconupon" />
    <scale factor=".75" />

    <!-- Browser -->
	<item component="ComponentInfo{com.android.browser/com.android.browser.BrowserActivity}" drawable="com_android_browser_browseractivity" />
    <item component="ComponentInfo{com.google.android.browser/com.android.browser.BrowserActivity}" drawable="com_android_browser_browseractivity" />
</resources>

<item component="ComponentInfo{com.sec.android.app.myfiles/com.sec.android.app.myfiles.MainActivity}" drawable="my_files" >
<item component="ComponentInfo{com.fds.infiniteflight/com.fds.infiniterunway.Program}" drawable="infiniteflight" />


Iconpack.xml

<?xml version="1.0" encoding="utf-8"?>
<resources>
    <string-array name="icon_pack" translatable="false">
		<item>com_android_browser_browseractivity</item>
	</string-array>
</resources>

<item>calculator</item>
<item>contacts</item>
<item>mi_naem_is_jeff</item>
<item>my_files</item>
<item>infiniteflight</item>


Drawable.xml

<?xml version="1.0" encoding="utf-8"?>
<resources>
    <version>1</version>
    <item drawable="com_android_browser_browseractivity" />
</resources>

<item drawable="calculator" />
<item


Thanks in advance!
Re: Error won't go away. [message #1707598 is a reply to message #1707582] Mon, 07 September 2015 18:36 Go to previous messageGo to next message
Nitin Dahyabhai is currently offline Nitin DahyabhaiFriend
Messages: 3877
Registered: July 2009
Senior Member

The key phrase is "root element", as in you get one under which all other elements must go. Each of your examples has more than one top-level element.

Nitin Dahyabhai
Eclipse Web Tools Platform
Re: Error won't go away. [message #1707694 is a reply to message #1707598] Tue, 08 September 2015 14:03 Go to previous messageGo to next message
Roberts Ruskuls is currently offline Roberts RuskulsFriend
Messages: 2
Registered: September 2015
Junior Member
So how can I fix that?
Re: Error won't go away. [message #1707706 is a reply to message #1707694] Tue, 08 September 2015 15:43 Go to previous messageGo to next message
Nitin Dahyabhai is currently offline Nitin DahyabhaiFriend
Messages: 3877
Registered: July 2009
Senior Member

In the context of this "Holo Launcher", I do not know, but it is a correct error message for XML files in general.

Nitin Dahyabhai
Eclipse Web Tools Platform

[Updated on: Tue, 08 September 2015 15:43]

Report message to a moderator

Re: Error won't go away. [message #1707717 is a reply to message #1707706] Tue, 08 September 2015 17:08 Go to previous message
Eric Rizzo is currently offline Eric RizzoFriend
Messages: 3071
Registered: July 2009
Senior Member
This isn't really an Eclipse question; the XML you have is malformed and you need to understand the structure that's expected in order to correct it.
Previous Topic:Unable to download Eclipse on my computer
Next Topic:cant download eclipse IDE for java EE developers
Goto Forum:
  


Current Time: Sun Oct 25 18:05:50 GMT 2020

Powered by FUDForum. Page generated in 0.03350 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top