Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home »  » Eclipse 4 » Migration from E3 + compat to Pure E4 application (how to create a pure e4 application by removing 3.x dependencies ?)
Migration from E3 + compat to Pure E4 application [message #1706505] Thu, 27 August 2015 12:32 Go to next message
Patrik Suzzi is currently offline Patrik SuzziFriend
Messages: 86
Registered: June 2010
Location: Imola, Italy
Member

Hallo,

I have an Eclipse 3.x application project that was migrated into Eclipse 4.x by using the compatibility layer.

Now I am investigating the migration to a pure Eclipse 4 application, and I will need a suggestion:

To investigate which classes to fix I will remove all the 3.x dependencies from the manifest of my project.

As example, I know that org.eclipse.core.runtime is part of eclipse 3.x and it must be removed to have a pure E4 application.

Now, my questions are:

  1. Is there a list of the dependencies to remove in order to have a pure e4 application?
  2. Do you think this is a good way to investigate the migration from e3.x to e4.x ?


Thanks in advance
Kind Regards,
Patrik
Re: Migration from E3 + compat to Pure E4 application [message #1706507 is a reply to message #1706505] Thu, 27 August 2015 12:41 Go to previous messageGo to next message
Thomas Schindl is currently offline Thomas SchindlFriend
Messages: 6365
Registered: July 2009
Senior Member
On 27.08.15 14:32, Patrik Suzzi wrote:
> Hallo,
> I have an Eclipse 3.x application project that was migrated into Eclipse
> 4.x by using the compatibility layer.
> Now I am investigating the migration to a pure Eclipse 4 application,
> and I will need a suggestion:
> To investigate which classes to fix I will remove all the 3.x
> dependencies from the manifest of my project.
> As example, I know that org.eclipse.core.runtime is part of eclipse 3.x
> and it must be removed to have a pure E4 application.

This is wrong core.runtime can still used.

The problem are:
* org.elipse.ui
* org.eclipse.ui.workbench
* org.eclipse.ui.ide
* org.eclipse.ui.editors

> Now, my questions are:
> Is there a list of the dependencies to remove in order to have a pure e4
> application?

Most likely the ones above are ok

> Do you think this is a good way to investigate the migration from e3.x
> to e4.x ?

It highly depends on your application. If you used 3.x EditorPart you
might have to redo many things!

Tom
Re: Migration from E3 + compat to Pure E4 application [message #1706513 is a reply to message #1706507] Thu, 27 August 2015 13:04 Go to previous message
Dirk Fauth is currently offline Dirk FauthFriend
Messages: 2539
Registered: July 2012
Senior Member
Hi,

Simon Scholz and I are currently writing a migration tutorial. The resulting code can be found here: https://github.com/fipro78/e4-cookbook-migration-guide

In short, everything that starts with org.eclipse.ui is bad when talking about plain e4. Wink

I agree with Tom that it depends on your application whether it is a good idea to migrate or not. Typically I would always suggest to migrate, but I also faced issues where it is not possible to migrate easily. Especially when third-party plug-ins come into play it might get a mess if they are not migrated. In such a case you are forced to have the compatibility layer in play, and this might lead to strange situations.

Regarding the EditorPart, well, maybe it depends to the EditorPart, but we also migrated one in our migration tutorial, and sure it is some more work, but also not too bad. Wink
Previous Topic:Eclipse e4 Cheatsheets
Next Topic:How to get a specific MPart in a command handler with DI
Goto Forum:
  


Current Time: Sun Dec 17 00:34:43 GMT 2017

Powered by FUDForum. Page generated in 0.01985 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software