Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » ATL » Metamodel registering
Metamodel registering [message #1706196] Mon, 24 August 2015 16:43 Go to next message
Edoaurd Batot is currently offline Edoaurd BatotFriend
Messages: 90
Registered: March 2015
Member
Hi folks,

that must be an easy one but...

I reinstalled Eclipse 4.5 (and EMF and ATL) and the "register metamodel" which I used to use a lot has disappeared !

I've tried from the marketplace installing-uninstalling ATL and EMF, but it didn't work.

Any guess ?

Or any manner to register metamodels from ecore file at Eclipse statrup ?

Thanks,
Have a good day.
Edouard
Re: Metamodel registering [message #1706200 is a reply to message #1706196] Mon, 24 August 2015 17:59 Go to previous messageGo to next message
Edoaurd Batot is currently offline Edoaurd BatotFriend
Messages: 90
Registered: March 2015
Member
As the question doesn't look like any interesting to the numerous ones passing by, I'll add a simple question :

is there any way to register once and for all a metamodel in Eclipse ?

That, would be the must.

Thanks,
Edouard
Re: Metamodel registering [message #1706230 is a reply to message #1706200] Tue, 25 August 2015 07:31 Go to previous messageGo to next message
Sylvain EVEILLARD is currently offline Sylvain EVEILLARDFriend
Messages: 551
Registered: July 2009
Senior Member
generate them using EMF and load the plugins in your ATL environment.
Re: Metamodel registering [message #1706314 is a reply to message #1706230] Tue, 25 August 2015 15:19 Go to previous messageGo to next message
Edoaurd Batot is currently offline Edoaurd BatotFriend
Messages: 90
Registered: March 2015
Member
Thanks Sylvain for your answer.
Im not working in an ATL environnement really - well, Im not sure about what does it mean. I did some school work with ATL, and I so have the perspective in Eclipse available with the magic Register button.

I need to check manually some programmatically generated instances. I<m working on an instance generator. ATL perspective offers me to register the metamodels, but I dont do anything with ATL.
It also sounds like the EMF geration doesn<t work properly as it doesnt generate anything...

[Updated on: Tue, 25 August 2015 15:20]

Report message to a moderator

Re: Metamodel registering [message #1707396 is a reply to message #1706314] Fri, 04 September 2015 13:14 Go to previous messageGo to next message
Dimitris Kolovos is currently offline Dimitris KolovosFriend
Messages: 1474
Registered: July 2009
Location: York, UK
Senior Member

Hi Edouard,

Epsilon provides an Ecore metamodel registration facility in case this is still of interest (see "Register library.ecore" section of [1]).

Cheers,
Dimitris

[1] http://www.eclipse.org/epsilon/doc/articles/reflective-emf-tutorial/

[Updated on: Fri, 04 September 2015 13:19]

Report message to a moderator

Re: Metamodel registering [message #1707449 is a reply to message #1707396] Fri, 04 September 2015 18:50 Go to previous message
Dennis Wagelaar is currently offline Dennis WagelaarFriend
Messages: 350
Registered: September 2012
Location: Belgium
Senior Member

This should still work, but you need to switch to the ATL perspective to get the context menu option back. I don't think anything changed in that department between Luna and Mars...

index.php/fa/23149/0/

index.php/fa/23150/0/


Cheers,
Dennis
Previous Topic:Unable to resolve OCL pivot variable types in standalone mode during an ATL transformation
Next Topic:[EMFTVM] Editor confused by double quotes (")
Goto Forum:
  


Current Time: Mon Sep 25 22:36:33 GMT 2017

Powered by FUDForum. Page generated in 0.02657 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software