Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Port is configured with wrong protocol "http"(When jetty is configured with SSL it shows that the port is not configured for https protocol)
Port is configured with wrong protocol "http" [message #1705692] Tue, 18 August 2015 12:10
Santodip Chakrabarty is currently offline Santodip ChakrabartyFriend
Messages: 1
Registered: August 2015
Junior Member
The jetty server is configured as below:

<beans
<bean id="defaultHandler" class="org.eclipse.jetty.server.handler.DefaultHandler" />

<bean id="sslContext" class="org.eclipse.jetty.util.ssl.SslContextFactory">
<property name="keyStore" value="/nfs/uh04/jgruszcz/userspace/work/Bsg_2.5.0.27/install/bsg/conf/com.orga.oslee.ra.ws.Core-R1.2.3/keystore"/>
<property name="keyStorePassword" value="changeit" />
<property name="keyManagerPassword" value="changeit" />
<property name="trustStore" value="/nfs/uh04/jgruszcz/userspace/work/Bsg_2.5.0.27/install/bsg/conf/com.orga.oslee.ra.ws.Core-R1.2.3/keystore" />
<property name="trustStorePassword" value="changeit"/>
</bean>

<bean id="sslnioSelectChannelConnector"
class="org.eclipse.jetty.server.ssl.SslSelectChannelConnector">
<property name="port" value="12132" />
<property name="host" value="riops67" />
<constructor-arg ref="sslContext" />
</bean>

<cxf:bus>
<cxf:features>

<cxf:logging />

</cxf:features>
</cxf:bus>

<httpj:engine-factory bus="cxf" id="https">


<httpj:identifiedTLSServerParameters
id="secure">
<httpj:tlsServerParameters>
<sec:keyManagers keyPassword="changeit">
<sec:keyStore type="JKS" password="changeit"
file="/nfs/uh04/jgruszcz/userspace/work/Bsg_2.5.0.27/install/bsg/conf/com.orga.oslee.ra.ws.Core-R1.2.3/keystore" />
</sec:keyManagers>
<sec:trustManagers>
<sec:keyStore type="JKS" password="changeit"
file="/nfs/uh04/jgruszcz/userspace/work/Bsg_2.5.0.27/install/bsg/conf/com.orga.oslee.ra.ws.Core-R1.2.3/keystore" />
</sec:trustManagers>
<sec:clientAuthentication required="false" />
</httpj:tlsServerParameters>
</httpj:identifiedTLSServerParameters>

<httpj:engine host="riops67" port="12132">
<httpj:tlsServerParametersRef id="secure" />
<httpj:threadingParameters minThreads="100"
maxThreads="200" />
<httpj:connector>
<ref bean="sslnioSelectChannelConnector"/>
</httpj:connector>
<httpj:sessionSupport>false</httpj:sessionSupport>
</httpj:engine>
</httpj:engine-factory>
</beans>

When I try to run the server it shows the below error:

javax.xml.ws.WebServiceException: java.lang.RuntimeException: Port 12131 is configured with wrong protocol "http" for "https://abc12:12131/getMyData"
at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.initializeBean(AbstractAutowireCapableBeanFactory



Any help is highly appreciated
Thanks in advance
Previous Topic:Weblogic 12c server not starting in Ubuntu 14.04
Next Topic:getting eclipse php programs to run in Apache server
Goto Forum:
  


Current Time: Wed Sep 18 22:16:16 GMT 2019

Powered by FUDForum. Page generated in 0.03365 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top