Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Can't run simple hello world project: "....exe has stopped working"
Can't run simple hello world project: "....exe has stopped working" [message #1705491] Mon, 17 August 2015 07:23 Go to next message
matt matt is currently offline matt mattFriend
Messages: 4
Registered: August 2015
Junior Member
Hello everybody!

I'm pretty frustrated with how much more difficult it is to get Eclipse working
for simply C coding as opposed to using Notepad++ with cygwin.

I've followed the instructions (from a website which I cannot link because I'm new here...) to get this setup and working:

  1. install cygwin with gcc-core, gdb, make
  2. add "C:\cygwin64\bin" to Path
  3. install eclipse and start a "C Project"
  4. select "Hello World ANSI C Project" and the toolchain "Cygwin GCC"

Then I first build the program which works as expected. But running results in
the message "Hello_World.exe has stopped working". When I execute the
exe in cygwin however, it works fine!


What's the problem with Eclipse?
Re: Can't run simple hello world project: "....exe has stopped working" [message #1705587 is a reply to message #1705491] Mon, 17 August 2015 15:50 Go to previous messageGo to next message
Russell Bateman is currently offline Russell BatemanFriend
Messages: 3799
Registered: July 2009
Location: Provo, Utah, USA
Senior Member

On 08/17/2015 05:51 AM, matt matt wrote:
> Hello everybody!
>
> I'm pretty frustrated with how much more difficult it is to get Eclipse
> working for simply C coding as opposed to using Notepad++ with cygwin.
>
> I've followed the instructions (from a website which I cannot link
> because I'm new here...) to get this setup and working:
>
> install cygwin with gcc-core, gdb, make
> add "C:\cygwin64\bin" to Path
> install eclipse and start a "C Project"
> select "Hello World ANSI C Project" and the toolchain "Cygwin GCC"
>
> Then I first build the program which works as expected. But running
> results in
> the message "Hello_World.exe has stopped working". When I execute the
> exe in cygwin however, it works fine!
>
> What's the problem with Eclipse?

There's a separate Eclipse CDT forum.
Re: Can't run simple hello world project: "....exe has stopped working" [message #1705590 is a reply to message #1705587] Mon, 17 August 2015 16:35 Go to previous message
matt matt is currently offline matt mattFriend
Messages: 4
Registered: August 2015
Junior Member
Ok, thanks.
Previous Topic:Eclipse Mars : PDE Headless build is not generating zip file for Mac OS X
Next Topic:Weblogic 12c server not starting in Ubuntu 14.04
Goto Forum:
  


Current Time: Sat Sep 21 00:29:21 GMT 2019

Powered by FUDForum. Page generated in 0.03130 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top