Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Incompatible JVM(I have read eclipse.ini and still have no idea how to make eclipse run.)
Incompatible JVM [message #1703529] Sun, 02 August 2015 15:23 Go to next message
Richard Hausman is currently offline Richard HausmanFriend
Messages: 1
Registered: August 2015
Junior Member
Firstly, thank you in advance for any and all help. I am a complete newcomer!
So, I installed eclipse. Then, I installed java 8. Then, I tried to open eclipse. Following message appears: "Version 1.6.0_65 of the JVM is not suitable for this product. Version: 1.6 or greater is required.". So, after visiting this forum, I read about Eclipse.ini, in order to "specify a java virtual machine" as recomended. However, Eclipse.ini was meaningless to me because it was too complex. I couldn't understand it. Please, I want only to open Eclipse. I do not understand why this is so difficult. When I installed the Arduino IDE, for example, I just clicked download and began writing code.
Help would be greatly appreciated. I am a beginner, so please keep you language simple!
Many thanks,
Richard Hausman.
Re: Incompatible JVM [message #1703536 is a reply to message #1703529] Sun, 02 August 2015 20:31 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 30451
Registered: July 2009
Senior Member
Richard,

Maybe try the new installer:

http://www.eclipse.org/downloads/installer.php

It will detect all your JVMs and use one that will work, or tell you
which one you need if none of them will work.


On 02/08/2015 9:10 PM, Richard Hausman wrote:
> Firstly, thank you in advance for any and all help. I am a complete
> newcomer!
> So, I installed eclipse. Then, I installed java 8. Then, I tried to
> open eclipse. Following message appears: "Version 1.6.0_65 of the JVM
> is not suitable for this product. Version: 1.6 or greater is
> required.". So, after visiting this forum, I read about Eclipse.ini,
> in order to "specify a java virtual machine" as recomended. However,
> Eclipse.ini was meaningless to me because it was too complex. I
> couldn't understand it. Please, I want only to open Eclipse. I do not
> understand why this is so difficult. When I installed the Arduino IDE,
> for example, I just clicked download and began writing code.
> Help would be greatly appreciated. I am a beginner, so please keep you
> language simple! Many thanks,
> Richard Hausman.
Re: Incompatible JVM [message #1703628 is a reply to message #1703536] Mon, 03 August 2015 17:49 Go to previous message
Eric Rizzo is currently offline Eric RizzoFriend
Messages: 3071
Registered: July 2009
Senior Member
Can you specify what about the eclipse.ini wiki page was unclear? We've spent a lot of effort to make those instructions as clear as possible, and highlight just the portion you need to add or edit.
Previous Topic:Eclipse Mars crashes when editing the build path
Next Topic:Eclipse doesn't recognize TomEE
Goto Forum:
  


Current Time: Thu Sep 19 14:31:59 GMT 2019

Powered by FUDForum. Page generated in 0.02855 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top