Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Requesting Help w/ Eclipse+Epic+Strawberry(Newbie with Perl looking for help)
icon4.gif  Requesting Help w/ Eclipse+Epic+Strawberry [message #1703078] Tue, 28 July 2015 13:47 Go to next message
Brian Collins is currently offline Brian CollinsFriend
Messages: 2
Registered: July 2015
Junior Member
Okay... so I haven't touched coding of any sort in several years, and even then, what I knew was real basic stuff (some web design, a dabble of C++ and VB, nothing special).

My current gig has me working with perl scripts quite often. All fine and dandy, I've got no problem learning something new. Thing is, we use Eclipse (Kepler) with the EPIC plugin and Strawberry Perl. Nobody has had to install this for several years, and thus nobody can recall how to do so.

I've trawled around Google for a bit, but didn't find anything that was able to help me get up and running. As it stands, I've got all three pieces installed. I can create a new PERL project and file, and put in some basic code (just a simple print command to test). However, when I try to run it, I get:

"The selction cannot be launched, and there are no recent launches."

I followed the instructions I found here
http://www.epic-ide.org/running_perl_scripts_within_eclipse/entry.htm
to try and use Strawberry as the external program... except the arguments they provide don't work (tried to modify them for the strawberry installation instead of the command prompt, but with no success).

I'm at a loss on how to get these applications integrated. Can someone give me a nudge in the right direction?

Thanks!

[Updated on: Tue, 28 July 2015 14:03] by Moderator

Report message to a moderator

Re: Requesting Help w/ Eclipse+Epic+Strawberry [message #1703094 is a reply to message #1703078] Tue, 28 July 2015 14:14 Go to previous message
Brian Collins is currently offline Brian CollinsFriend
Messages: 2
Registered: July 2015
Junior Member
UPDATE - okay, I think I may have gotten it... functional? In Run Configurations, I configured it for the specific project and individual file I wanted to execute...

My question at this point - does this have to be done for EACH file in the project I want to run? There's no way to get Eclipse to just execute the currently-open script as a perl file?
Previous Topic:Status 404 with BuildJ2EEWebApp WTP tutorial
Next Topic:my eclipse doesnt start beacuse of the ''13'' problem
Goto Forum:
  


Current Time: Thu Sep 19 15:11:07 GMT 2019

Powered by FUDForum. Page generated in 0.03071 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top