Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » EMF Feature Model - Feature Diagram Editor will not install on Mars(org.eclipse.featuremodel.diagrameditor 0.8.0) requires 'bundle org.eclipse.emf.ecoretools.diagram 1.0.0' but it could not be found)
EMF Feature Model - Feature Diagram Editor will not install on Mars [message #1702082] Sun, 19 July 2015 09:21 Go to next message
David Roberts is currently offline David RobertsFriend
Messages: 3
Registered: July 2015
Junior Member
Hi,

Please can you help or let me know what I am doing wrong.
Does anyone know if the EMF Feature Model Diagram Editor runs on Mars?
If not, which release?

I'm trying to install the EMF Feature Model Diagram Editor on the Mars release.

1. Installed mars modelling package 64bits on Windows 7 (64bit)
from : https://www.eclipse.org/downloads/packages/eclipse-modeling-tools/marsr

Run Eclipse:

2. help->install new software:
- from https://wiki.eclipse.org/EMF_Feature_Model/Feature_Diagram_Editor:
- add:

Name: emf feature model
Location: https://wiki.eclipse.org/EMF_Feature_Model#Installation
Pending..., then:

EMF Feature Model:

- EMF Feature Model Meta Model 0.8.0
- EMF Feature Model Evaluation 0.8.0
- EMF Feature Diagram Editor 0.8.0

Select all
Next

Wait a while... then this is displayed:

Feature Diagram Editor will not be installed.
Click on Show Original Error:

Details:
Cannot complete the install because one or more required items could not be found.
Software being installed: Feature Diagram Editor 0.8.0 (org.eclipse.featuremodel.diagrameditor.feature.feature.group 0.8.0)
Missing requirement: Feature Diagram Editor 0.8.0 (org.eclipse.featuremodel.diagrameditor 0.8.0) requires 'bundle org.eclipse.emf.ecoretools.diagram 1.0.0' but it could not be found
Cannot satisfy dependency:
From: Feature Diagram Editor 0.8.0 (org.eclipse.featuremodel.diagrameditor.feature.feature.group 0.8.0)
To: org.eclipse.featuremodel.diagrameditor [0.8.0]

Cancel

3. Did some google searching. Looks like this is part of ecoretools?

Then Help-> Install Modelling Components
Pick EcoreTools (updates)
A Ecore Diagram Editor, version 3.0.0.201507011611 is listed.

That is installed, successfully and Eclipse restarts.

Repeat Step 2 above.

Same Error.
Re: EMF Feature Model - Feature Diagram Editor will not install on Mars [message #1702169 is a reply to message #1702082] Mon, 20 July 2015 13:04 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 30457
Registered: July 2009
Senior Member
David,

From what you write, it looks like it depends on a quite old version of
Ecore Tools (and so it's not a very active project producing update site
based on recent versions of other projects). It looks like you can fine
the old version of Ecore tools from this page:

https://www.eclipse.org/ecoretools/download.html

You'd need to add that to your "Available update sites" preferences.

On 19/07/2015 10:57 PM, David Roberts wrote:
> Hi,
>
> Please can you help or let me know what I am doing wrong.
> Does anyone know if the EMF Feature Model Diagram Editor runs on Mars?
> If not, which release?
> I'm trying to install the EMF Feature Model Diagram Editor on the Mars
> release.
>
> 1. Installed mars modelling package 64bits on Windows 7 (64bit)
> from :
> https://www.eclipse.org/downloads/packages/eclipse-modeling-tools/marsr
>
> Run Eclipse:
>
> 2. help->install new software:
> - from
> https://wiki.eclipse.org/EMF_Feature_Model/Feature_Diagram_Editor:
> - add:
>
> Name: emf feature model
> Location: https://wiki.eclipse.org/EMF_Feature_Model#Installation
> Pending..., then:
>
> EMF Feature Model:
>
> - EMF Feature Model Meta Model 0.8.0
> - EMF Feature Model Evaluation 0.8.0
> - EMF Feature Diagram Editor 0.8.0
>
> Select all
> Next
>
> Wait a while... then this is displayed:
>
> Feature Diagram Editor will not be installed.
> Click on Show Original Error:
>
> Details:
> Cannot complete the install because one or more required items could
> not be found.
> Software being installed: Feature Diagram Editor 0.8.0
> (org.eclipse.featuremodel.diagrameditor.feature.feature.group 0.8.0)
> Missing requirement: Feature Diagram Editor 0.8.0
> (org.eclipse.featuremodel.diagrameditor 0.8.0) requires 'bundle
> org.eclipse.emf.ecoretools.diagram 1.0.0' but it could not be found
> Cannot satisfy dependency:
> From: Feature Diagram Editor 0.8.0
> (org.eclipse.featuremodel.diagrameditor.feature.feature.group 0.8.0)
> To: org.eclipse.featuremodel.diagrameditor [0.8.0]
>
> Cancel
> 3. Did some google searching. Looks like this is part of ecoretools?
>
> Then Help-> Install Modelling Components
> Pick EcoreTools (updates)
> A Ecore Diagram Editor, version 3.0.0.201507011611 is listed.
>
> That is installed, successfully and Eclipse restarts.
>
> Repeat Step 2 above.
> Same Error.
>
Re: EMF Feature Model - Feature Diagram Editor will not install on Mars [message #1702263 is a reply to message #1702169] Tue, 21 July 2015 08:19 Go to previous messageGo to next message
David Roberts is currently offline David RobertsFriend
Messages: 3
Registered: July 2015
Junior Member
Thanks Ed, I had tried using the older versions of the ecoretools
The legacy 1.x ones might the dependency rules, but the editor does not appear to run properly. Some of the user interface for creating features and sub-features appears to be missing.

Re: EMF Feature Model - Feature Diagram Editor will not install on Mars [message #1702326 is a reply to message #1702263] Tue, 21 July 2015 14:37 Go to previous message
Ed Merks is currently offline Ed MerksFriend
Messages: 30457
Registered: July 2009
Senior Member
David,

Given the project is not providing updates that work with the latest,
they don't appear to be very active. You might try asking on
https://dev.eclipse.org/mailman/listinfo/featuremodel-dev what the
current state of the project is...

On 21/07/2015 10:19 AM, David Roberts wrote:
> Thanks Ed, I had tried using the older versions of the ecoretools
> The legacy 1.x ones might the dependency rules, but the editor does
> not appear to run properly. Some of the user interface for creating
> features and sub-features appears to be missing.
>
>
Previous Topic:Which Eclipse Mars for PyDev
Next Topic:Eclypse 3.2 fails to start after Java update
Goto Forum:
  


Current Time: Fri Sep 20 19:13:00 GMT 2019

Powered by FUDForum. Page generated in 0.03106 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top