Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Eclypse 3.2 fails to start after Java update (Java update)
Eclypse 3.2 fails to start after Java update [message #1701922] Thu, 16 July 2015 17:05 Go to next message
Jay Mackey is currently offline Jay MackeyFriend
Messages: 2
Registered: November 2014
Junior Member
I have Eclypse 3.2 on a 64b machine that has been running fine with Java 8.45. When I updated Java to 8.51 Eclypse now does not start with a Exit=13 error. If I uninstall Eclypse and reinstall it, will it (1)fix the problem and (2) will it affect my .java and .class files in my workspace? Unfortunately I failed to create a restore point before I updated Java. See attachment for Exit = 13 Error.
Re: Eclypse 3.2 fails to start after Java update [message #1701945 is a reply to message #1701922] Fri, 17 July 2015 02:51 Go to previous messageGo to next message
Phil Freihofner is currently offline Phil FreihofnerFriend
Messages: 38
Registered: May 2010
Member
Same exact problem just occurred for me, including error message. The error message is kind of hard to decipher. However, there are some older answers that may help:
http://stackoverflow.com/questions/4945178/cannot-run-eclipse-jvm-terminated-exit-code-13
http://www.ashout.com/fix-java-started-returned-exit-code13-eclipse/

In my case, I suspect I allowed Java to update with a 32-bit version when I running a 64 bit Eclipse and PC. Am going through redoing the update now to make sure I have 64-bit. Will report back if/when I learn more.

[EDIT] Yes, reinstall, with 64-bit worked. Actually, what I did was reinstall my Java SE JDK, and had it put in the public JRE (which overwrote the update I did that put in the 32-bit version). Eclipse is now happy and running again.

I hope this works for you as well.

[Updated on: Fri, 17 July 2015 02:58]

Report message to a moderator

Re: Eclypse 3.2 fails to start after Java update [message #1702045 is a reply to message #1701945] Fri, 17 July 2015 20:35 Go to previous messageGo to next message
Eric Rizzo is currently offline Eric RizzoFriend
Messages: 3071
Registered: July 2009
Senior Member
You should read all the Announcement messages at the top of the forum, especially the one titled Eclipse won't start? READ THIS FIRST...

[Updated on: Fri, 17 July 2015 20:36]

Report message to a moderator

icon10.gif  Re: Eclypse 3.2 fails to start after Java update [message #1702357 is a reply to message #1701945] Tue, 21 July 2015 17:28 Go to previous message
Jay Mackey is currently offline Jay MackeyFriend
Messages: 2
Registered: November 2014
Junior Member
Thanks Phil, your solution worked for me as well. I simply reinstalled Java JDK 1.8_45 and Eclipse started working again. I suspect the same thing happened where I got my versions of Java(32b or 64b) mixed up. I later discovered I also had a 32b version of JSE on my machine that was for my Foxfire browser, I have since updated that to the 64b version. Firefox is running OK now.
Previous Topic:EMF Feature Model - Feature Diagram Editor will not install on Mars
Next Topic:Install JDK 8 (not JRE 8) to run Eclipse Mars on OS X Mavericks
Goto Forum:
  


Current Time: Tue Sep 17 16:58:56 GMT 2019

Powered by FUDForum. Page generated in 0.02977 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top