Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » ServerTools (WTP) » Publish Creates Jars With No Resources(Publishing a webapp to a Tomcat 6.0 server results in jars in WEB-INF/lib directory with resources (e.g. *.xsd) files removed only from subprojects)
Publish Creates Jars With No Resources [message #1701896] Thu, 16 July 2015 14:26
Brian Heilig is currently offline Brian HeiligFriend
Messages: 1
Registered: July 2015
Junior Member
I've been struggling with an issue for about a week now and could really use your help. This issue arises from a legacy project so providing source is difficult. I thought I'd ask the question first before I create a small reproducer, hoping someone will know the answer.

I have a Tomcat 6.0 Server with one webapp. This webapp has many maven dependencies. The dependencies that are from other projects in the workspace are copied to the WEB-INF/lib folder with missing files. It appears everything that is not a .class file is removed (or never inserted, depending on whether the jar is copied from the project's target directory (it doesn't appear to be) or built on demand). The webapp fails when executed because the files can not be found. Jar files from external maven dependencies (e.g. spring-beans-2.5.6.jar) DO have all of the files (e.g. org\springframework\beans\factory\xml\spring-beans-2.5.xsd). It appears these dependencies are copied from my local maven repository.

Thanks in advance for your help!
Previous Topic:Missing WSDL Editor
Next Topic:Xerces Validation Issues with Honour All schema Locations
Goto Forum:
  


Current Time: Sun Jul 22 20:10:31 GMT 2018

Powered by FUDForum. Page generated in 0.01768 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top