Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » ServerTools (WTP) » How to add a Web Preview Server to Eclipse Mars(Web Preview Server problem)
How to add a Web Preview Server to Eclipse Mars [message #1701725] Wed, 15 July 2015 09:21 Go to next message
Brian Hamill is currently offline Brian HamillFriend
Messages: 2
Registered: July 2015
Junior Member
I have been attempting to add a web preview server to my Eclipse Mars version. The only help I have found online is to open servers, right click, new, server then choose web preview from the IBM list.

I can not seem to find the IBM folder unless I install Liberty Profile, and even then there is no web preview server listed. Is there anywhere I can download the server to install it to my eclipse? I can't find anywhere online to do so.

Any help would be greatly appreciated. This is a fresh install of Eclipse Mars by the way.

Thanks,
Brian.
Re: How to add a Web Preview Server to Eclipse Mars [message #1702017 is a reply to message #1701725] Fri, 17 July 2015 13:54 Go to previous messageGo to next message
Larry Isaacs is currently offline Larry IsaacsFriend
Messages: 1354
Registered: July 2009
Senior Member
On 7/15/2015 8:27 AM, Brian Hamill wrote:
> I have been attempting to add a web preview server to my Eclipse Mars
> version. The only help I have found online is to open servers, right
> click, new, server then choose web preview from the IBM list.
>
> I can not seem to find the IBM folder unless I install Liberty Profile,
> and even then there is no web preview server listed. Is there anywhere I
> can download the server to install it to my eclipse? I can't find
> anywhere online to do so.
>
> Any help would be greatly appreciated. This is a fresh install of
> Eclipse Mars by the way.
>
> Thanks,
> Brian.

Just to confirm, am I correct in assuming the "HTTP Preview" and "J2EE
Preview" servers under the Basic category aren't what you are looking
for? I'm not aware of a "Web Preview" server.

Cheers,
Larry
Re: How to add a Web Preview Server to Eclipse Mars [message #1702094 is a reply to message #1702017] Sun, 19 July 2015 12:57 Go to previous messageGo to next message
Paul Os is currently offline Paul OsFriend
Messages: 1
Registered: July 2015
Junior Member
I have been trying to set up Eclipse Mars to debug a static web project on localhost. The Eclipse help says right-click Servers view > New Server > pick a server. The list is empty. I have tried setting up a server in numerous other ways within the Eclipse and project preferences and cannot find any help anywhere.

In project > Properties > Run/Debug Settings the New button is disabled.

In project > Properties > Servers it says, "This project is not associated with any servers".

Clicking 'Run as' shows 'Run on Server', but selecting this gives an error, "The selection cannot be run on any server". The Run Configurations list only shows 2 PHP options. I started to add a PHP server, but do not understand the settings, Path Map, etc.

There does not seem to be a run configuration to use with a static web project so why does it let you create static web projects?
Re: How to add a Web Preview Server to Eclipse Mars [message #1702161 is a reply to message #1702017] Mon, 20 July 2015 12:25 Go to previous messageGo to next message
Brian Hamill is currently offline Brian HamillFriend
Messages: 2
Registered: July 2015
Junior Member
Hi Larry,

I am talking about a server called "Web Preview Server". It has specific Ajax proxy settings. It can be seen here in this video on youtube:
"Installing WebSphere Application Server Liberty Profile" by youtuber "WASDev" ( I can't post the link unfortunately since my account is new)

I asked the video creator but they have yet to reply!

Thanks,
Brian.
Re: How to add a Web Preview Server to Eclipse Mars [message #1702197 is a reply to message #1701725] Mon, 20 July 2015 15:17 Go to previous message
Roberto Sanchez Herrera is currently offline Roberto Sanchez HerreraFriend
Messages: 36
Registered: January 2011
Member
Hello,
I guess you installed only the Liberty server adapter. To get the Web preview server, you need to install other features from WebSphere Developer Tools (WDT), besides the Liberty server adapter. I think installing the Web Development tools is enough.

Step 1 on this link explains how to install from Marketplace: https://developer.ibm.com/wasdev/downloads/liberty-profile-using-non-eclipse-environments/

Hope this helps.
Previous Topic:Deploy 'gradle war' output.
Next Topic:How to tell validator to ignore dojoType-attributes?
Goto Forum:
  


Current Time: Wed Sep 26 13:15:51 GMT 2018

Powered by FUDForum. Page generated in 0.02195 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top