Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse 4 » Eclipse Mars is a instance of Eclipse 4 or Eclipse 3.x RCP
Eclipse Mars is a instance of Eclipse 4 or Eclipse 3.x RCP [message #1701694] Wed, 15 July 2015 05:22 Go to next message
Jason Lynch is currently offline Jason LynchFriend
Messages: 11
Registered: July 2009
Junior Member
Hi guys,
we usually build RCP product based on 3.x RCP. Now seems many things are changed in Eclipse 4.x and we estimate the 4.x. I would like to know the current 4.5 Mars Eclipse IDE is a product of RCP 3.x or 4.x.

Thanks!
Re: Eclipse Mars is a instance of Eclipse 4 or Eclipse 3.x RCP [message #1705321 is a reply to message #1701694] Thu, 13 August 2015 18:40 Go to previous message
Brian de Alwis is currently offline Brian de AlwisFriend
Messages: 685
Registered: January 2012
Senior Member

Any Eclipse RCP running on 4.x is itself an Eclipse 4 application. The somewhat-unfortunately-named 'compatibility layer' implements the 3.x APIs and policies using Eclipse 4 constructs.

Brian.


Eclipse Platform committer. Ask me about Eclipse support, training, and consulting.
Previous Topic:Permanently remove part from the model
Next Topic:"Install new software" from the welcome page
Goto Forum:
  


Current Time: Thu Nov 23 16:31:34 GMT 2017

Powered by FUDForum. Page generated in 0.02047 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software