Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » General (non-technical) » Polish users » Eclipse docbook - wygenerowany pdf bez polskich znaków(znak # zamiast polskich znaków)
Eclipse docbook - wygenerowany pdf bez polskich znaków [message #1701607] Tue, 14 July 2015 11:54 Go to next message
Katarzyna Simeonidis is currently offline Katarzyna SimeonidisFriend
Messages: 1
Registered: July 2015
Junior Member
Cześć,

Jestem nowa na forum i mam problem z dodatkiem docbook w eclipse. Po wygenerowaniu pliku, który już mam gotowy w pdfie nie mam polskich znaków, zamiast tego mam znaki #.

Wiem, że problem leży po stronie Apache FOP, jednak nie umiem tego skonfigurować.

Próbowałam skonfigurować plik fop-user-configuration.xml następująco:

<?xml version="1.0" encoding="UTF-8"?>

<fop version="1.0">

<renderers>
<renderer mime="application/pdf">
<fonts>
<font metrics-url="file:///c:/docbook/fonts/arial.xml" kerning="yes" embed-url="c:/docbook/fonts/arial.ttf">
<font-triplet name="Arial" style="normal" weight="normal"/>
<font-triplet name="ArialMT" style="normal" weight="normal"/>
</font>
<font metrics-url="file:///c:/docbook/fonts/arialb.xml" kerning="yes" embed-url="c:/docbook/fonts/arialb.ttf">
<font-triplet name="Arial" style="normal" weight="bold"/>
<font-triplet name="ArialMT" style="normal" weight="bold"/>
</font>
<font metrics-url="file:///c:/docbook/fonts/ariali.xml" kerning="yes" embed-url="c:/docbook/fonts/ariali.ttf">
<font-triplet name="Arial" style="italic" weight="normal"/>
<font-triplet name="ArialMT" style="italic" weight="normal"/>
</font>
<font metrics-url="file:///c:/docbook/fonts/arialbi.xml" kerning="yes" embed-url="c:/docbook/fonts/arialbi.ttf">
<font-triplet name="Arial" style="italic" weight="bold"/>
<font-triplet name="ArialMT" style="italic" weight="bold"/>
</font>

<font metrics-url="file:///c:/docbook/fonts/times.xml" kerning="yes" embed-url="c:/docbook/fonts/times.ttf">
<font-triplet name="Times" style="normal" weight="normal"/>
<font-triplet name="TimesMT" style="normal" weight="normal"/>
</font>
<font metrics-url="file:///c:/docbook/fonts/timesb.xml" kerning="yes" embed-url="c:/docbook/fonts/timesb.ttf">
<font-triplet name="Times" style="normal" weight="bold"/>
<font-triplet name="TimesMT" style="normal" weight="bold"/>
</font>
<font metrics-url="file:///c:/docbook/fonts/timesi.xml" kerning="yes" embed-url="c:/docbook/fonts/timesi.ttf">
<font-triplet name="Times" style="italic" weight="normal"/>
<font-triplet name="TimesMT" style="italic" weight="normal"/>
</font>
<font metrics-url="file:///c:/docbook/fonts/timesbi.xml" kerning="yes" embed-url="c:/docbook/fonts/timesbi.ttf">
<font-triplet name="Times" style="italic" weight="bold"/>
<font-triplet name="TimesMT" style="italic" weight="bold"/>
</font>
</fonts>
</renderer>
</renderers>
</fop>

Jednak nadal nie działa.

Prosiłabym o pomoc
Re: Eclipse docbook - wygenerowany pdf bez polskich znaków [message #1702366 is a reply to message #1701607] Tue, 21 July 2015 20:17 Go to previous message
Tomasz Zarna is currently offline Tomasz ZarnaFriend
Messages: 172
Registered: July 2009
Senior Member
Co to ma wspólnego z Eclipse?
Previous Topic:Problemy z Mavenem
Next Topic:Eclipse C/C++ OS X problem z GDB
Goto Forum:
  


Current Time: Thu Sep 20 13:28:26 GMT 2018

Powered by FUDForum. Page generated in 0.04686 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top