Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Java missing in preferences
Java missing in preferences [message #1701354] Sun, 12 July 2015 13:44 Go to next message
Rudolf Polzer is currently offline Rudolf PolzerFriend
Messages: 4
Registered: July 2015
Junior Member
I have a new installation of Debian Linux with Eclipse 3.8.1
When typing "java -version" on the command line, I get

java version "1.7.0_79"
OpenJDK Runtime Environment (IcedTea 2.5.5) (7u79-2.5.5-1~deb8u1)
OpenJDK 64-Bit Server VM (build 24.79-b02, mixed mode)

But Eclipse shows no Java in Window/Preferences, so I can't compile.


edit: corrected Eclipse version

[Updated on: Mon, 13 July 2015 15:39]

Report message to a moderator

Re: Java missing in preferences [message #1701443 is a reply to message #1701354] Mon, 13 July 2015 13:41 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 30312
Registered: July 2009
Senior Member
Rudolf,

Eclipse doesn't have version numbers as high as 8.8.1 so who knows what
you have pre-installed. Best you install one that supports Java
development from https://www.eclipse.org/downloads/

On 13/07/2015 1:22 AM, Rudolf Polzer wrote:
> I have a new installation of Debian Linux with Eclipse 8.8.1
> When typing "java -version" on the command line, I get
>
> java version "1.7.0_79"
> OpenJDK Runtime Environment (IcedTea 2.5.5) (7u79-2.5.5-1~deb8u1)
> OpenJDK 64-Bit Server VM (build 24.79-b02, mixed mode)
>
> But Eclipse shows no Java in Window/Preferences, so I can't compile.
>
>
Re: Java missing in preferences [message #1701454 is a reply to message #1701443] Mon, 13 July 2015 14:02 Go to previous messageGo to next message
Rudolf Polzer is currently offline Rudolf PolzerFriend
Messages: 4
Registered: July 2015
Junior Member
Sorry for my mistyping:
The Eclipse version is 3.8.1
Re: Java missing in preferences [message #1701474 is a reply to message #1701454] Mon, 13 July 2015 15:07 Go to previous messageGo to next message
Nitin Dahyabhai is currently offline Nitin DahyabhaiFriend
Messages: 3437
Registered: July 2009
Senior Member

Version 3.8.1 installed using what download?

Nitin Dahyabhai
Eclipse Web Tools Platform
Re: Java missing in preferences [message #1701484 is a reply to message #1701474] Mon, 13 July 2015 15:37 Go to previous messageGo to next message
Rudolf Polzer is currently offline Rudolf PolzerFriend
Messages: 4
Registered: July 2015
Junior Member
downloaded using Debian ap-get install eclipse
Re: Java missing in preferences [message #1701489 is a reply to message #1701484] Mon, 13 July 2015 16:45 Go to previous messageGo to next message
Rudolf Polzer is currently offline Rudolf PolzerFriend
Messages: 4
Registered: July 2015
Junior Member
I changed to version 4.5.0 Eclipse for Java downloaded directly - now the problem is solved.
Re: Java missing in preferences [message #1701492 is a reply to message #1701489] Mon, 13 July 2015 17:05 Go to previous messageGo to next message
Nitin Dahyabhai is currently offline Nitin DahyabhaiFriend
Messages: 3437
Registered: July 2009
Senior Member

Odds are that Debian has split Eclipse into different packages, making it possible to install the Platform without the Java tools, and giving that platform package the name "eclipse". You would have needed other packages to add the Java tools, then, but that wouldn't change 3.8.1 being years old.

Nitin Dahyabhai
Eclipse Web Tools Platform
Re: Java missing in preferences [message #1701498 is a reply to message #1701484] Mon, 13 July 2015 18:00 Go to previous message
Ed Merks is currently offline Ed MerksFriend
Messages: 30312
Registered: July 2009
Senior Member
Rudolf,

I'm not sure what's in that Eclipse package, but it's definitely old.
Better to install one you've downloaded from the link I gave you.

On 13/07/2015 5:37 PM, Rudolf Polzer wrote:
> downloaded using Debian ap-get install eclipse
Previous Topic:Eclipse workbench menu constants
Next Topic:Maven Dependency
Goto Forum:
  


Current Time: Sat Jul 20 22:14:42 GMT 2019

Powered by FUDForum. Page generated in 0.03102 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top