Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Empty string arguement causes Java launch to fail.( )
Empty string arguement causes Java launch to fail. [message #1699547] Thu, 25 June 2015 02:38 Go to next message
Sagun Singh is currently offline Sagun SinghFriend
Messages: 1
Registered: June 2015
Junior Member
My program repeatedly failed to launch, giving me a "Error: Could not find or load main class ". My compiled .class runs with a OutOfMemoryException when I use "java MainLoop.class" in the Terminal under Linux, where MainLoop.class is the class with a valid main method.

I have not modified the project settings / folders / files outside of Eclipse. I am using a fresh Mars install of Eclipse and am using the default project settings.

I did have to change the JDK / JRE to point to Oracles' Java 8, since I am running on a 32-bit Debian Jessie system. However, everything seems to point to the installation being complete.

When I checked the process Properties in the Debug view, though, Eclipse seemed to be entering a empty string (or two just two random quotation marks?)

The commands go like this:


  • /usr/lib/jvm/jdk1.8.0_45/bin/java
  • ""
  • -Dfile.encoding=UTF-8
  • /home/notes/Code/Java/ProjectEulerJava/bin
  • us.notes.MainLoop


Does anyone knows why Eclipse is doing this (or if it affects my program launching in any way)? Sorry if this question has been answered before - my Google skills are not exactly up to date, and I couldn't find any recently submitted bugs like this.
Re: Empty string arguement causes Java launch to fail. [message #1778836 is a reply to message #1699547] Fri, 22 December 2017 11:08 Go to previous messageGo to next message
Bernát K lló is currently offline Bernát K llóFriend
Messages: 2
Registered: July 2009
Junior Member
I've seen the same error. The solution was to:

Window > Preferences > Java > Installed JREs
select the default jre
Edit...
in Default VM arguments, there was an unncecessary variable reference that resulted in an empty string.

No idea how it made it there.
Re: Empty string arguement causes Java launch to fail. [message #1778906 is a reply to message #1778836] Sat, 23 December 2017 14:27 Go to previous message
Nitin Dahyabhai is currently offline Nitin DahyabhaiFriend
Messages: 3175
Registered: July 2009
Senior Member

Which variable was it referencing?

Nitin Dahyabhai
Eclipse Web Tools Platform
Previous Topic:JSP font
Next Topic:Help with connecting to SQL Server PHP
Goto Forum:
  


Current Time: Wed Jun 20 19:30:48 GMT 2018

Powered by FUDForum. Page generated in 0.02920 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top