Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » JBoss causing trouble in upgrade from Kepler to Luna
icon5.gif  JBoss causing trouble in upgrade from Kepler to Luna [message #1699356] Tue, 23 June 2015 14:48 Go to next message
Tom Catullo is currently offline Tom CatulloFriend
Messages: 1
Registered: June 2015
Junior Member
I am attempting to upgrade my current Kepler installation to Luna. I have added the Luna download repository to my Eclipse, and upon checking for updates, I receive the following errors.

Does anyone have any ideas as to what I can do to get the upgrade working? Thanks!

Cannot complete the install because of a conflicting dependency.
  Software being installed: Eclipse IDE for Java EE Developers 4.4.2.20150219-0708 (epp.package.jee 4.4.2.20150219-0708)
  Software currently installed: JBossAS Tools 2.4.101.Final-v20140318-1509-B179 (org.jboss.ide.eclipse.as.feature.feature.group 2.4.101.Final-v20140318-1509-B179)
  Only one of the following can be installed at once: 
    Core Runtime 3.9.0.v20130326-1255 (org.eclipse.core.runtime 3.9.0.v20130326-1255)
    Core Runtime 3.10.0.v20140318-2214 (org.eclipse.core.runtime 3.10.0.v20140318-2214)
  Cannot satisfy dependency:
    From: Eclipse IDE for Java EE Developers 4.4.2.20150219-0708 (epp.package.jee 4.4.2.20150219-0708)
    To: org.eclipse.epp.package.jee.feature.feature.group [4.4.2.20150219-0708]
  Cannot satisfy dependency:
    From: Eclipse e4 Rich Client Platform 1.3.101.v20150204-1353 (org.eclipse.e4.rcp.feature.group 1.3.101.v20150204-1353)
    To: org.eclipse.core.runtime [3.10.0.v20140318-2214]
  Cannot satisfy dependency:
    From: EPP Java EE IDE Feature 4.4.2.20150219-0708 (org.eclipse.epp.package.jee.feature.feature.group 4.4.2.20150219-0708)
    To: org.eclipse.platform.feature.group [4.4.2.v20150204-1700]
  Cannot satisfy dependency:
    From: Eclipse Platform 4.4.2.v20150204-1700 (org.eclipse.platform.feature.group 4.4.2.v20150204-1700)
    To: org.eclipse.rcp.feature.group [4.4.2.v20150204-1700]
  Cannot satisfy dependency:
    From: Eclipse RCP 4.4.2.v20150204-1700 (org.eclipse.rcp.feature.group 4.4.2.v20150204-1700)
    To: org.eclipse.e4.rcp.feature.group [1.3.101.v20150204-1353]
  Cannot satisfy dependency:
    From: JBoss AS Core Plug-in 2.4.101.Final-v20140318-1509-B179 (org.jboss.ide.eclipse.as.core 2.4.101.Final-v20140318-1509-B179)
    To: bundle org.eclipse.core.runtime [3.7.0,3.10.0)
  Cannot satisfy dependency:
    From: JBossAS Tools 2.4.101.Final-v20140318-1509-B179 (org.jboss.ide.eclipse.as.feature.feature.group 2.4.101.Final-v20140318-1509-B179)
    To: org.jboss.ide.eclipse.as.core 2.3.0
Re: JBoss causing trouble in upgrade from Kepler to Luna [message #1699370 is a reply to message #1699356] Tue, 23 June 2015 18:21 Go to previous message
Nitin Dahyabhai is currently offline Nitin DahyabhaiFriend
Messages: 3523
Registered: July 2009
Senior Member

You'll need to find and install the corresponding updates to the JBoss Tools, for Luna.

Nitin Dahyabhai
Eclipse Web Tools Platform
Previous Topic:I can't set a breakpoint ?
Next Topic:Crazy colour scheme
Goto Forum:
  


Current Time: Tue Nov 12 18:22:30 GMT 2019

Powered by FUDForum. Page generated in 0.03031 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top