Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse 4 » org.eclipse.core.runtime error on migration to Eclipse luna 4.4.2
org.eclipse.core.runtime error on migration to Eclipse luna 4.4.2 [message #1698081] Wed, 10 June 2015 22:31 Go to next message
VAIBHAV KUMAR JAIN is currently offline VAIBHAV KUMAR JAINFriend
Messages: 3
Registered: June 2015
Junior Member
We have migrated from eclipse 3.8 to eclipse Luna . After removing all compilation errors , trying to launch my application but application is not able to launch . We are running on jdk1.7.0_45.
Below are the logs which is getting print in console also attached full log file .

!SESSION 2015-06-08 16:26:13.354 -----------------------------------------------
eclipse.buildId=unknown
java.version=1.7.0_45
java.vendor=Oracle Corporation
BootLoader constants: OS=win32, ARCH=x86_64, WS=win32, NL=en_US
Framework arguments: -product com.csc.fs.pa.producteditor.application.product
Command-line arguments: -product com.csc.fs.pa.producteditor.application.product -data C:\EcliUpgra\pA_workspace -dev file:C:/Upgrade/eclipse-test/eclipse-java-luna-SR2-win32-x86_64/eclipse/testWorkspace/.metadata/.plugins/org.eclipse.pde.core/ProductEditor.product-Ecl-Upg/dev.properties -os win32 -ws win32 -arch x86_64 -consoleLog

!ENTRY org.eclipse.equinox.ds 2 0 2015-06-08 16:26:48.608
!MESSAGE [SCR] Enabling components of bundle org.eclipse.ui.trace did not complete in 30000 ms

!ENTRY org.eclipse.equinox.ds 2 0 2015-06-08 16:26:48.609
!MESSAGE [SCR - WorkThread] Timeout occurred! Thread was blocked on processing [QueuedJob] WorkPerformer: org.eclipse.equinox.internal.ds.SCRManager@764d86d6; actionType 1

!ENTRY org.eclipse.core.runtime 4 0 2015-06-08 16:26:53.698
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Unable to acquire the state change lock for the module: osgi.identity; osgi.identity="org.eclipse.core.runtime"; type="osgi.bundle"; version:Version="3.10.0.v20140318-2214"; singleton:="true" [id=655] STARTED [STARTED]
at org.eclipse.osgi.container.Module.lockStateChange(Module.java:329)
at org.eclipse.osgi.container.Module.start(Module.java:389)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1582)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1562)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1533)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1476)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)

Can anyone help me in resolving the error.

Also I have pasted org.eclipse.core.runtime.compatibility.auth_3.2.300.v20120523-2004.jar in plugin folder because org.eclipse.core.runtime.compatibility.auth_3.2.300.v20120523-2004.jar shows dependency on above jar
  • Attachment: error.txt
    (Size: 13.33KB, Downloaded 106 times)
Re: org.eclipse.core.runtime error on migration to Eclipse luna 4.4.2 [message #1698475 is a reply to message #1698081] Mon, 15 June 2015 21:02 Go to previous messageGo to next message
Brian de Alwis is currently offline Brian de AlwisFriend
Messages: 672
Registered: January 2012
Senior Member

This sounds like a symptom where a bundle's activator is blocking the UI thread. Take a stack dump and see what else is going on.

Brian.


Eclipse Platform committer. Ask me about Eclipse support, training, and consulting.
Re: org.eclipse.core.runtime error on migration to Eclipse luna 4.4.2 [message #1698641 is a reply to message #1698475] Tue, 16 June 2015 21:03 Go to previous messageGo to next message
VAIBHAV KUMAR JAIN is currently offline VAIBHAV KUMAR JAINFriend
Messages: 3
Registered: June 2015
Junior Member
Brian

How could I do that ?
Re: org.eclipse.core.runtime error on migration to Eclipse luna 4.4.2 [message #1698729 is a reply to message #1698641] Wed, 17 June 2015 13:25 Go to previous message
Brian de Alwis is currently offline Brian de AlwisFriend
Messages: 672
Registered: January 2012
Senior Member

VAIBHAV KUMAR JAIN wrote on Tue, 16 June 2015 17:03
How could I do that ?


See the following page for different approaches:

https://wiki.eclipse.org/How_to_report_a_deadlock

In your case it may be helpful to use the remote debug connection approach so that you can poke about in the stack and see what's happening.

Brian.


Eclipse Platform committer. Ask me about Eclipse support, training, and consulting.
Previous Topic:Model Spy not working
Next Topic:NatTable and context menu from fragment.e4xmi
Goto Forum:
  


Current Time: Sun Nov 19 14:31:46 GMT 2017

Powered by FUDForum. Page generated in 0.02053 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software