Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Eclipse doesn't start since I updated my Mac
Eclipse doesn't start since I updated my Mac [message #1697790] Mon, 08 June 2015 13:42 Go to next message
Yashar Sadeghi is currently offline Yashar SadeghiFriend
Messages: 2
Registered: June 2015
Junior Member
Some time ago, I updated my Mac to OSX Yosemite 10.10.3

Now, when I want to start my Eclipse (Kepler; sorry I can't recall the exact version) it shows the warning:

The JVM shared library "/Library/Java/JavaVirtualMachines/jdk1.8.0_45.jdk/Contents/Home/bin/../jre/lib/server/libjvm.dylib" does not contain the JNI_CreateJavaVM symbol.
I tried installing the newest JDK and Java version but didn't help at all. I really need to use Eclipse. Any advices? Sad

Thanks in advance.
Re: Eclipse doesn't start since I updated my Mac [message #1697797 is a reply to message #1697790] Mon, 08 June 2015 14:12 Go to previous messageGo to next message
Nitin Dahyabhai is currently offline Nitin DahyabhaiFriend
Messages: 3518
Registered: July 2009
Senior Member

Did you try uninstalling the old one?

Nitin Dahyabhai
Eclipse Web Tools Platform
Re: Eclipse doesn't start since I updated my Mac [message #1697798 is a reply to message #1697790] Mon, 08 June 2015 14:13 Go to previous messageGo to next message
Eric Rizzo is currently offline Eric RizzoFriend
Messages: 3071
Registered: July 2009
Senior Member
Did you read the Announcement message at the top of this forum titled "Eclipse won't start? READ THIS FIRST"
Re: Eclipse doesn't start since I updated my Mac [message #1697868 is a reply to message #1697797] Tue, 09 June 2015 08:27 Go to previous messageGo to next message
Yashar Sadeghi is currently offline Yashar SadeghiFriend
Messages: 2
Registered: June 2015
Junior Member
No I didn't, wouldn't the work space disappear once you uninstalled it?
Re: Eclipse doesn't start since I updated my Mac [message #1698186 is a reply to message #1697868] Fri, 12 June 2015 00:49 Go to previous message
Russell Bateman is currently offline Russell BatemanFriend
Messages: 3798
Registered: July 2009
Location: Provo, Utah, USA
Senior Member

On 06/09/2015 02:27 AM, Yashar Sadeghi wrote:
> No I didn't, wouldn't the work space disappear once you uninstalled it?

Eclipse isn't "uninstalled" in the normal sense. You can remove the
eclipse subdirectory. Unless you put your workspace inside that
subdirectory, it wasn't deleted when you removed Eclipse.
Previous Topic:Isuses during migration from 3.8 to 4.4.2 Luna
Next Topic:Having to manually add project include path everytime?
Goto Forum:
  


Current Time: Tue Oct 22 19:56:45 GMT 2019

Powered by FUDForum. Page generated in 0.02878 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top