Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » M2T (model-to-text transformation) » Could not initialize class org.artop.aal.autosar40.validation.listeners.ProblemMarkerIntegrity40List(Could not initialize class org.artop.aal.autosar40.validation.listeners.ProblemMarkerIntegrity40List)
Could not initialize class org.artop.aal.autosar40.validation.listeners.ProblemMarkerIntegrity40List [message #1697489] Thu, 04 June 2015 10:52
Babu M is currently offline Babu MFriend
Messages: 20
Registered: February 2012
Junior Member
I am trying to do the setup for xtend2 environment using
-luna-dsl-sr2 with
-sphinx-0.8
-artop-4.4.1 as target... when i launch the eclipse instance, and create an xtend project, i am experiencing the following error. could any one help to me.

{{{
!ENTRY org.eclipse.ui 4 0 2015-06-04 16:08:15.577
!MESSAGE Unhandled event loop exception
!STACK 0
java.lang.NoClassDefFoundError: Could not initialize class org.artop.aal.autosar40.validation.listeners.ProblemMarkerIntegrity40Listener
at org.artop.aal.autosar40.validation.internal.ValidationEditingDomainFactoryListener.<init>(ValidationEditingDomainFactoryListener.java:29)
at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
at sun.reflect.NativeConstructorAccessorImpl.newInstance(Unknown Source)
at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(Unknown Source)
at java.lang.reflect.Constructor.newInstance(Unknown Source)
at java.lang.Class.newInstance(Unknown Source)
}}}
Previous Topic:Acceleo - search for class
Next Topic:[Acceleo] Cannot access EClass objects declared in a referenced .ecore file
Goto Forum:
  


Current Time: Sun Jul 22 18:39:42 GMT 2018

Powered by FUDForum. Page generated in 0.01772 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top