Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » Papyrus » Migrating projects (models and profiles) from Eclipse Indigo to Eclipse Luna(Imported models in Eclipse Luna get corrupted and are not displayed correctly)
Migrating projects (models and profiles) from Eclipse Indigo to Eclipse Luna [message #1697435] Wed, 03 June 2015 21:45 Go to next message
Tomas Balderas is currently offline Tomas BalderasFriend
Messages: 64
Registered: July 2010
Member
Hello everybody

I wanted to import projects (UML diagrams and profiles) developed in Papyrus running in Eclipse Indigo to Papyrus on Eclipse Luna. I cannot longer sustain my Eclipse Indigo since it does not support Java 8.

My problem is that after importing in Eclipse Luna, I got error messages (Repair stereotypes) and the models built using my profiles are not displayed as I built them in Eclipse Indigo. Any suggestion to perform a proper migration?

Thanks for your help.

Tomás


/TB
Re: Migrating projects (models and profiles) from Eclipse Indigo to Eclipse Luna [message #1697465 is a reply to message #1697435] Thu, 04 June 2015 08:15 Go to previous messageGo to next message
Camille Letavernier is currently offline Camille LetavernierFriend
Messages: 920
Registered: February 2011
Senior Member
Hi Tomas,

The migration is supposed to be straight foward (Entirely automatic), although Papyrus Luna has a better detection for errors than Indigo. In Papyrus 0.8/Indigo, it was very easy to get "broken" stereotypes left in the model, e.g. when deleting some stereotyped elements. Papyrus 1.0/Luna will detect them and propose to clean them up.

Also, Papyrus Luna now integrates a notion of Themes (Through stylesheets) which didn't exist in Indigo. So the default appearance might have changed (e.g. Gradients and Element Icons are enabled by default, and elements are now blue instead of white). This can be solved by disabling the new default Theme, and using the "Black & White" one instead. To do that, go to Window > Preferences > Papyrus > CSS Theme > Select "Black & White". Not that the Theme is a user-specific preference and doesn't affect the model directly (Only how you see it). Different users can use different Themes with the same model.

HTH,
Camille


Camille Letavernier
Re: Migrating projects (models and profiles) from Eclipse Indigo to Eclipse Luna [message #1697719 is a reply to message #1697465] Sun, 07 June 2015 09:39 Go to previous messageGo to next message
Tomas Balderas is currently offline Tomas BalderasFriend
Messages: 64
Registered: July 2010
Member
Thank you for your kind answering Camille

I set Eclipse Luna up as indicated but when I run my imported Acceleo transformation on my imported Papyrus model extended by the corresponding profile I get several errors, incomprehensible at first sight. I think I will have to play with settings some more to replicate the conditions set in Eclipse Indigo. However, I am still worried that the imported model is broken Confused

Thanks. Kindest regards.

Tomás


/TB
Re: Migrating projects (models and profiles) from Eclipse Indigo to Eclipse Luna [message #1697755 is a reply to message #1697719] Mon, 08 June 2015 08:05 Go to previous messageGo to next message
Camille Letavernier is currently offline Camille LetavernierFriend
Messages: 920
Registered: February 2011
Senior Member
Hi,

I can't help much with Acceleo, except that Papyrus Luna uses UML 2.5 whereas Papyrus Indigo uses UML 2.3, so you may need to change the source URI of your transformations.

Regarding Papyrus itself, what kind of issues do you have? Are you able to open your model, visualize your diagrams, find your profiles and stereotypes?

If you are using plug-ins to deploy your profiles and libraries, you should be aware that the Papyrus plug-ins (And extension points) have changed between Indigo and Juno, so you will probably also need to update them. Especially, "org.eclipse.papyrus.extensionpoints.uml2" became "org.eclipse.papyrus.uml.extensionpoints"

HTH,
Camille


Camille Letavernier
Re: Migrating projects (models and profiles) from Eclipse Indigo to Eclipse Luna [message #1697764 is a reply to message #1697719] Mon, 08 June 2015 09:16 Go to previous messageGo to next message
Ed Willink is currently offline Ed WillinkFriend
Messages: 6589
Registered: July 2009
Senior Member
Hi

" I get several errors, incomprehensible at first sight"

You will need to share them to get any help.

Indigo to Luna is a major advance UML2-wise and Papyrus-wise.

I recommend (successfully) validating all your *.uml models in the UML
Model Editor and then in Papyrus before making any attempt to use Acceleo.

Use of UML with Acceleo or any other transformation tool is non-trivial
because of the setup, so you probably want to get a fresh hello world
example working first and then apply those settings to your example.
Replicating conditions set in Eclipse Indigo is almost certainly a bad
way to go.

NB. In Luna, UMLResourcesUtil.init() performs all of the required
initialization that previously required considerable manual effort.

Regards

Ed Willink


On 07/06/2015 10:39, Tomas Balderas wrote:
> Thank you for your kind answering Camille
>
> I set Eclipse Luna up as indicated but when I run my imported Acceleo
> transformation on my imported Papyrus model extended by the
> corresponding profile I get several errors, incomprehensible at first
> sight. I think I will have to play with settings some more to
> replicate the conditions set in Eclipse Indigo. However, I am still
> worried that the imported model is broken :?
> Thanks. Kindest regards.
>
> Tomás
Re: Migrating projects (models and profiles) from Eclipse Indigo to Eclipse Luna [message #1698654 is a reply to message #1697764] Wed, 17 June 2015 03:29 Go to previous messageGo to next message
Tomas Balderas is currently offline Tomas BalderasFriend
Messages: 64
Registered: July 2010
Member
Hello Ed.

I imported my Acceleo project into Eclipse Luna, update the Build Path to point to JavaSE-1.8 by modifying MANIFEST.MF and made sure no warning or errors were indicated along the name of my project in Project Explorer. This is what I got when I ran the transformation:

Exception in thread "main" org.eclipse.emf.ecore.resource.impl.ResourceSetImpl$1DiagnosticWrappedException: org.eclipse.emf.ecore.xmi.PackageNotFoundException: Package with uri 'http:///schemas/BitBlockFlow/_klgxQN0kEeGTaraYMNN65g/46' not found. (file:/C:/Users/Tomas%20Balderas%20C/workspace-luna/ccc.inaoep.mx.papyrus.testprofile/model.uml, 643, 116)
	at org.eclipse.emf.ecore.resource.impl.ResourceSetImpl.handleDemandLoadException(ResourceSetImpl.java:319)
	at org.eclipse.emf.ecore.resource.impl.ResourceSetImpl.demandLoadHelper(ResourceSetImpl.java:278)
	at org.eclipse.emf.ecore.resource.impl.ResourceSetImpl.getResource(ResourceSetImpl.java:406)
	at org.eclipse.acceleo.common.utils.ModelUtils.load(ModelUtils.java:391)
	at org.eclipse.acceleo.common.utils.ModelUtils.load(ModelUtils.java:356)
	at org.eclipse.acceleo.engine.service.AbstractAcceleoGenerator.initialize(AbstractAcceleoGenerator.java:475)
	at ccc.inaoep.mx.acceleo.bbf2detailedlist.main.Bbf2detailedlist.<init>(Bbf2detailedlist.java:90)
	at ccc.inaoep.mx.acceleo.bbf2detailedlist.main.Bbf2detailedlist.main(Bbf2detailedlist.java:144)
Caused by: org.eclipse.emf.ecore.xmi.PackageNotFoundException: Package with uri 'http:///schemas/BitBlockFlow/_klgxQN0kEeGTaraYMNN65g/46' not found. (file:/C:/Users/Tomas%20Balderas%20C/workspace-luna/ccc.inaoep.mx.papyrus.testprofile/model.uml, 643, 116)
	at org.eclipse.emf.ecore.xmi.impl.XMLHandler.getPackageForURI(XMLHandler.java:2625)
	at org.eclipse.emf.ecore.xmi.impl.XMLHandler.getFactoryForPrefix(XMLHandler.java:2458)
	at org.eclipse.emf.ecore.xmi.impl.XMLHandler.createObjectByType(XMLHandler.java:1335)
	at org.eclipse.emf.ecore.xmi.impl.XMLHandler.createTopObject(XMLHandler.java:1504)
	at org.eclipse.emf.ecore.xmi.impl.XMLHandler.processElement(XMLHandler.java:1026)
	at org.eclipse.emf.ecore.xmi.impl.XMIHandler.processElement(XMIHandler.java:81)
	at org.eclipse.emf.ecore.xmi.impl.XMLHandler.startElement(XMLHandler.java:1008)
	at org.eclipse.emf.ecore.xmi.impl.XMLHandler.startElement(XMLHandler.java:719)
	at org.eclipse.emf.ecore.xmi.impl.XMIHandler.startElement(XMIHandler.java:163)
	at com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser.startElement(Unknown Source)
	at com.sun.org.apache.xerces.internal.parsers.AbstractXMLDocumentParser.emptyElement(Unknown Source)
	at com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl.scanStartElement(Unknown Source)
	at com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl$FragmentContentDriver.next(Unknown Source)
	at com.sun.org.apache.xerces.internal.impl.XMLDocumentScannerImpl.next(Unknown Source)
	at com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl.scanDocument(Unknown Source)
	at com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(Unknown Source)
	at com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(Unknown Source)
	at com.sun.org.apache.xerces.internal.parsers.XMLParser.parse(Unknown Source)
	at com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser.parse(Unknown Source)
	at com.sun.org.apache.xerces.internal.jaxp.SAXParserImpl$JAXPSAXParser.parse(Unknown Source)
	at com.sun.org.apache.xerces.internal.jaxp.SAXParserImpl.parse(Unknown Source)
	at org.eclipse.emf.ecore.xmi.impl.XMLLoadImpl.load(XMLLoadImpl.java:175)
	at org.eclipse.emf.ecore.xmi.impl.XMLResourceImpl.doLoad(XMLResourceImpl.java:261)
	at org.eclipse.emf.ecore.resource.impl.ResourceImpl.load(ResourceImpl.java:1518)
	at org.eclipse.emf.ecore.resource.impl.ResourceImpl.load(ResourceImpl.java:1297)
	at org.eclipse.emf.ecore.resource.impl.ResourceSetImpl.demandLoad(ResourceSetImpl.java:259)
	at org.eclipse.emf.ecore.resource.impl.ResourceSetImpl.demandLoadHelper(ResourceSetImpl.java:274)
	... 6 more


Does this exception have anything to do with a broken imported model? Any hint will be useful. I appreciate your help.

Thanks.


/TB
Re: Migrating projects (models and profiles) from Eclipse Indigo to Eclipse Luna [message #1698669 is a reply to message #1698654] Wed, 17 June 2015 08:01 Go to previous message
Camille Letavernier is currently offline Camille LetavernierFriend
Messages: 920
Registered: February 2011
Senior Member
Hi,

Quote:
Does this exception have anything to do with a broken imported model? Any hint will be useful. I appreciate your help.


It seems that Acceleo can't find one of your custom profiles. Since I'm not sure that Acceleo is able to properly handle UML Models Migration, you should try the following:

- Open your Profile model with Papyrus Luna
- Save it (To save it in Luna format)
- Open your profiled Model with Papyrus Luna
- Take any repair action that is required (Remove broken stereotypes, update profile applications, remove profile applications that don't exist anymore...)
- Save it
- Run the Acceleo transformation again

I don't really know how Acceleo works with custom profiles, but I think it relies on a separate runtime environment (Different from the one in which you open the model), so maybe it also needs some additional dependencies? Especially some dependencies to your custom profile(s)

HTH,
Camille


Camille Letavernier
Previous Topic:Revision Mode for Papyrus
Next Topic:EAST-ADL tutorial
Goto Forum:
  


Current Time: Sat Feb 22 20:26:10 GMT 2020

Powered by FUDForum. Page generated in 0.08377 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top