Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » EMF » [CDO] Builing cdo on builserver
[CDO] Builing cdo on builserver [message #1697432] Wed, 03 June 2015 21:15 Go to next message
Leonid Ripeynih is currently offline Leonid RipeynihFriend
Messages: 150
Registered: February 2012
Senior Member
Hello!

We're trying to build our own CDO with some patches (not yet ready for uploading to CDO upstream) we've developed. I set up a build on my local machine (Windows box), and it works nicely. However, it failt on buildserver (linux) with the following error:

ERROR: No repository found containing: osgi.bundle,oracle.database.driver,7.5.0.201505070900

However, earlier in the log it reports:
oracle.database.driver:osgi.bundle: Trying provider p2(http://download.oracle.com/otn_software/oepe/luna[http://download.oracle.com/otn_software/oepe/luna])
[23:44:54]oracle.database.driver:osgi.bundle: Found match 7.5.0.201505070900


Am I missing something?
Thanks in advance!
Re: [CDO] Builing cdo on builserver [message #1697449 is a reply to message #1697432] Thu, 04 June 2015 03:49 Go to previous messageGo to next message
Eike Stepper is currently offline Eike StepperFriend
Messages: 6441
Registered: July 2009
Senior Member
Am 03.06.2015 um 23:15 schrieb Leonid Ripeynih:
> Hello!
>
> We're trying to build our own CDO with some patches (not yet ready for uploading to CDO upstream) we've developed. I
> set up a build on my local machine (Windows box), and it works nicely. However, it failt on buildserver (linux) with
> the following error:
>
>
> ERROR: No repository found containing: osgi.bundle,oracle.database.driver,7.5.0.201505070900
>
> However, earlier in the log it reports:
>
> oracle.database.driver:osgi.bundle: Trying provider
> p2(http://download.oracle.com/otn_software/oepe/luna[http://download.oracle.com/otn_software/oepe/luna])
> [23:44:54]oracle.database.driver:osgi.bundle: Found match 7.5.0.201505070900
>
>
> Am I missing something?
We use http://download.oracle.com/otn_software/oepe/12.1.3.6/mars/repository

Cheers
/Eike

----
http://www.esc-net.de
http://thegordian.blogspot.com
http://twitter.com/eikestepper


Re: [CDO] Builing cdo on builserver [message #1697468 is a reply to message #1697432] Thu, 04 June 2015 08:40 Go to previous message
Leonid Ripeynih is currently offline Leonid RipeynihFriend
Messages: 150
Registered: February 2012
Senior Member
I have noticed the upstream commits have fixed this problem,
http://git.eclipse.org/c/cdo/cdo.git/commit/?id=d81f151f081270b64ecc899a08aa5e0d6cb75258
http://git.eclipse.org/c/cdo/cdo.git/commit/?id=4081da310415064109c93a4ceab85cc3c77e722a
http://git.eclipse.org/c/cdo/cdo.git/commit/?id=3275f403ce3861282d467780d06663df2c70a135

I pulled them and it works now. Thanks for the help!
Previous Topic:Validating Ecore models with independent OCL fragments
Next Topic:How can I integrate ecore models?
Goto Forum:
  


Current Time: Sun Aug 18 02:45:18 GMT 2019

Powered by FUDForum. Page generated in 0.02344 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top