Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » Papyrus » SysML diagram lost.("This diagram is contained in an unresolved resource")
SysML diagram lost. [message #1697200] Tue, 02 June 2015 11:48 Go to next message
Adrian Ww is currently offline Adrian WwFriend
Messages: 6
Registered: June 2015
Junior Member
Hi,

I'm a beginner with Papyrus utilisation and SysML description.
My problem is when I open my SysML model.di, all my diagrams are lost and there is the indication :
"This diagram is contained in an unresolved resource : platform:/resource/.../model.notation"

Moreover my model.notation is now empty (juste two code lines) and in my model explorer I have all my elements but not my diagrams, and I don't know why...

Is there a solution to fix this problem ?

Thanks for your help.
Re: SysML diagram lost. [message #1697211 is a reply to message #1697200] Tue, 02 June 2015 13:07 Go to previous messageGo to next message
Camille Letavernier is currently offline Camille LetavernierFriend
Messages: 932
Registered: February 2011
Senior Member
Hi Adrian,

Maybe the Eclipse Local History can restore the contents of the Notation model. Right click on *.notation > Compare with > Local History... (Or Replace with > Local History...)

Do you have any idea of what happened before you lost the diagrams? A specific entry in the error log maybe?

HTH,
Camille


Camille Letavernier
Re: SysML diagram lost. [message #1697215 is a reply to message #1697200] Tue, 02 June 2015 13:27 Go to previous messageGo to next message
Adrian Ww is currently offline Adrian WwFriend
Messages: 6
Registered: June 2015
Junior Member
Thank you so much Camille for the tips, I could retrieve all my diagrams !

Before to lost the diagrams I had a error message with the mention "model.notation and model.uml are not synchronised with the workspace" or anything like this.
So I closed Papyrus and when I opened it again everything was gone.

By the way thank you so much.
Re: SysML diagram lost. [message #1697217 is a reply to message #1697215] Tue, 02 June 2015 13:31 Go to previous message
Camille Letavernier is currently offline Camille LetavernierFriend
Messages: 932
Registered: February 2011
Senior Member
Hi Adrian,

Quote:
Thank you so much Camille for the tips, I could retrieve all my diagrams !


Glad to hear that! Smile

Quote:
Before to lost the diagrams I had a error message with the mention "model.notation and model.uml are not synchronised with the workspace" or anything like this.


This typically indicates that the files have been changed from outside Eclipse (e.g. from a text editor, or a Git/SVN client). Eclipse and Papyrus can detect these changes and ask to refresh the workspace/restart the editor to take the changes into account. So when this happens, you should be careful about "what" might have caused these changes.

Camille


Camille Letavernier
Previous Topic:Error during oomph Papyrus installation.
Next Topic:Papyrus build error
Goto Forum:
  


Current Time: Sun Nov 29 23:13:10 GMT 2020

Powered by FUDForum. Page generated in 0.02387 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top