Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Paho » Paho CClient Compatibility with Linux kernel and GCC version(Paho CClient supported kernel and gcc verions .)
icon9.gif  Paho CClient Compatibility with Linux kernel and GCC version [message #1696434] Tue, 26 May 2015 13:14 Go to next message
Harikrishnan P is currently offline Harikrishnan PFriend
Messages: 3
Registered: October 2014
Junior Member
Hai,
I am currently building an application that takes realtime data from some sensors and pass it to a MQTT Broker(using Apache ActiveMQ 5.11). As using a BeagleBone Black with linux kernel version ubuntu-armhf 3.8.13-bone30 with gcc version 4.6.3 and a Radxa Rock with linux kernel radxa 3.0.36+ with gcc version 4.8. The application works fine, but when i ran the same application in my system which have linux kernel version 3.16.0-37-generic and gcc version 4.8 terminates with a "malloc(): memory corruption (fast):" error. The gdb trace is also pasted:

*** Error in `/home/harikrishnan/Firmware/Debug/Firmware': malloc(): memory corruption (fast): 0x00007fffdc002620 ***

Program received signal SIGABRT, Aborted.
[Switching to Thread 0x7ffff2bb4700 (LWP 3900)]
0x00007ffff57abcc9 in __GI_raise (sig=sig@entry=6)
at ../nptl/sysdeps/unix/sysv/linux/raise.c:56
56 ../nptl/sysdeps/unix/sysv/linux/raise.c: No such file or directory.
(gdb) bt
#0 0x00007ffff57abcc9 in __GI_raise (sig=sig@entry=6)
at ../nptl/sysdeps/unix/sysv/linux/raise.c:56
#1 0x00007ffff57af0d8 in __GI_abort () at abort.c:89
#2 0x00007ffff57e8394 in __libc_message (do_abort=do_abort@entry=1,
fmt=fmt@entry=0x7ffff58f6b28 "*** Error in `%s': %s: 0x%s ***\n")
at ../sysdeps/posix/libc_fatal.c:175
#3 0x00007ffff57f30f7 in malloc_printerr (action=<optimized out>,
str=0x7ffff58f6ec8 "malloc(): memory corruption (fast)",
ptr=<optimized out>) at malloc.c:4996
#4 0x00007ffff57f5e04 in _int_malloc (av=0x7fffdc000020, bytes=32)
at malloc.c:3359
#5 0x00007ffff57f77b0 in __GI___libc_malloc (bytes=32) at malloc.c:2891
#6 0x00007ffff7b2ec85 in mymalloc (file=<optimized out>, line=276, size=96)
at src/Heap.c:147
#7 0x00007ffff7b32ce8 in MQTTClient_create (handle=0x7ffff2bb3e00,
serverURI=0x7ffff2bb3dd0 "tcp://(broker_ip):1883",
clientId=0x7fffdc0026f0 "(client_id)", persistence_type=1,
persistence_context=0x0) at src/MQTTClient.c:276
---Type <return> to continue, or q <return> to quit---
#8 0x000000000041a9e5 in MqttPublisher::publishSyncMessage (
this=0x7fffdc0008e0, topic=0x7fffdc002600 "topic",
clientId=0x7fffdc0026f0 "client_id",
payload=0x7fffb80013e8 "data") at ../src/MqttPublisher.cpp:188

I was hoping that by any chance the kernel version and gcc version depends. Also am using the paho cclient 1.0.2
Re: Paho CClient Compatibility with Linux kernel and GCC version [message #1696633 is a reply to message #1696434] Wed, 27 May 2015 14:56 Go to previous message
Ian Craggs is currently offline Ian CraggsFriend
Messages: 68
Registered: March 2013
Member
Hi. In the broadest terms, no, the Paho C client does not depend on any particular version of the Linux kernel or gcc. I'm assuming you're building it yourself.

Ian
Previous Topic:Paho c++ build problem
Next Topic:Paho C++ connect options problem
Goto Forum:
  


Current Time: Thu Nov 15 06:55:46 GMT 2018

Powered by FUDForum. Page generated in 0.02630 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top