Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » QVT-OML » Call qvto in Java : applyStereotype() does not work
Call qvto in Java : applyStereotype() does not work [message #1696425] Tue, 26 May 2015 12:37 Go to next message
Thanh Liem Phan is currently offline Thanh Liem PhanFriend
Messages: 28
Registered: January 2015
Junior Member
Hi, I have the following problem when trying to call qvto from Java.

I have a simulink2uml.qvto which transform simulink model into uml model. It works perfectly if i call it from the "Run configurations"/"Operational QVT Interpreter". All the uml stereotypes are well applied.

However, if I call the transfor from Java. There are always an error each time a stereotype is applied:
index.php/fa/21959/0/

Note that, the uml profiles (such as sysml) are well applied.
The below figure shows that the stereotypes are well applied in "Run config" mode:
index.php/fa/21960/0/

But it does not work when the transfor qvto is called from Java:
index.php/fa/21961/0/

All attributes of the applied stereotypes are missing.

Do you have any idea about this kind of problem?
Is there anyone encounter the same error?

Thanks for your help.
Re: Call qvto in Java : applyStereotype() does not work [message #1696606 is a reply to message #1696425] Wed, 27 May 2015 13:24 Go to previous messageGo to next message
Christopher Gerking is currently offline Christopher GerkingFriend
Messages: 57
Registered: April 2011
Member
Hi

Maybe your transformation violates the Eclipse UML "business logic", which
allows to apply a stereotype to an element only if that element is properly
contained (e.g., a Class must be contained in a Package first in order to
apply a stereotype successfully).

The reason why it works from the Operational QVT Interpreter could be, that
the Run configuration is invoked on a dynamic instance of your UML model,
which does not enforce the above restrictions. Is that possible?


Kind regards
Christopher Gerking



"Thanh Liem Phan" schrieb im Newsbeitrag
news:mk1pdv$u0g$1@xxxxxxxxe.org...

Hi, I have the following problem when trying to call qvto from Java.

I have a simulink2uml.qvto which transform simulink model into uml model. It
works perfectly if i call it from the "Run configurations"/"Operational QVT
Interpreter". All the uml stereotypes are well applied.

However, if I call the transfor from Java. There are always an error each
time a stereotype is applied:


Note that, the uml profiles (such as sysml) are well applied.
The below figure shows that the stereotypes are well applied in "Run config"
mode:


But it does not work when the transfor qvto is called from Java:


All attributes of the applied stereotypes are missing.

Do you have any idea about this kind of problem?
Is there anyone encounter the same error?

Thanks for your help.
Re: Call qvto in Java : applyStereotype() does not work [message #1696880 is a reply to message #1696606] Fri, 29 May 2015 08:24 Go to previous message
Thanh Liem Phan is currently offline Thanh Liem PhanFriend
Messages: 28
Registered: January 2015
Junior Member
Thanks Christopher,
I will verify my code following your suggest.
Best regards.
Previous Topic:intermediate classes in library?
Next Topic:Java model transformation with qvto
Goto Forum:
  


Current Time: Fri Nov 24 10:56:09 GMT 2017

Powered by FUDForum. Page generated in 0.01818 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software