Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Archived » Jubula » missing jar file
missing jar file [message #1694971] Mon, 11 May 2015 06:04 Go to next message
Romain Vianef is currently offline Romain VianefFriend
Messages: 32
Registered: April 2015
Member
Hello to everyone,

In the version of jubula, we need to make some dependencies to configure the project. In the section "2.5 General setup information" ( in the developerManual folder ), I found the required jar files except one : XPP3 min 1.1.4c .
Did you find it in your API folder? Or is it really necessary for the proceedings of my project ?


Thanks for your time.

Best regards.
Re: missing jar file [message #1695126 is a reply to message #1694971] Tue, 12 May 2015 08:06 Go to previous messageGo to next message
Sebastian Struckmann is currently offline Sebastian StruckmannFriend
Messages: 18
Registered: October 2013
Junior Member
Thanks for putting this in.

Your confusion is caused by the fact that in the documentation we use human-readable bundle names. XPP3 is the name for the org.xmlpull...jar which is located in the org.eclipse.jubula.tools-lib directory.

If you are looking for a sample setup, try the projects in the "org.eclipse.jubula.examples.api.adder" namespace in our repository
Re: missing jar file [message #1695154 is a reply to message #1695126] Tue, 12 May 2015 11:12 Go to previous messageGo to next message
Romain Vianef is currently offline Romain VianefFriend
Messages: 32
Registered: April 2015
Member
Thanks for the information.

The jar file "org.xmlpull-1.1.3.4_***.jar" is present but is already specified in the list of jar files.index.php/fa/21779/0/
So for me, XPP3 and org.xmlpull-1.1.3.4_***.jar can not be the same jar file, unless you talk about "org.xmlpull.jar" file. If yes, the number of version isn't necessary, isn't it ?
Re: missing jar file [message #1695899 is a reply to message #1695154] Wed, 20 May 2015 08:11 Go to previous messageGo to next message
Sebastian Struckmann is currently offline Sebastian StruckmannFriend
Messages: 18
Registered: October 2013
Junior Member
Thank you, Romain. There is indeed something wrong in the documentation. I opened a ticket at Eclipse, see http://bugs.eclipse.org/467652, to clarify what would be the correct way.

In short: "XPP3 min 1.1.4c" is not needed.
Re: missing jar file [message #1695926 is a reply to message #1695899] Wed, 20 May 2015 11:01 Go to previous message
Romain Vianef is currently offline Romain VianefFriend
Messages: 32
Registered: April 2015
Member
That's what I thought. I continued my test project without and it works.

Thanks for your answer.
Previous Topic:JUBULA8.1:Variable seems to have no effect on change inside eventhandler
Next Topic:To test an application with Jubula on Eclipse
Goto Forum:
  


Current Time: Sun Mar 03 10:48:01 GMT 2024

Powered by FUDForum. Page generated in 0.02327 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top