Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Getting Error message while starting Eclipse.(Error message exit code = 13)
Getting Error message while starting Eclipse. [message #1693494] Fri, 24 April 2015 14:24 Go to next message
Somen Singh is currently offline Somen SinghFriend
Messages: 1
Registered: April 2015
Junior Member
Hi All,

I went through the post here but still could not find myself comfortable.

I installed an eclipse i.e eclipse-java-luna-SR2-win32-x86_64
Java versions:
I have multiple versions installed.
1. jdk1.8.0_45
2. jre1.8.0_40
3. jre1.8.0_45

I tried adding the -vm into eclipse.ini file but still no help.

My eclipse.ini file looks like this:

-startup
plugins/org.eclipse.equinox.launcher_1.3.0.v20140415-2008.jar
--launcher.library
plugins/org.eclipse.equinox.launcher.win32.win32.x86_64_1.1.200.v20150204-1316
-product
org.eclipse.epp.package.java.product
--launcher.defaultAction
openFile
--launcher.XXMaxPermSize
256M
-showsplash
org.eclipse.platform
--launcher.XXMaxPermSize
256m
--launcher.defaultAction
openFile
--launcher.appendVmargs

-vm
C:/Program Files (x86)/Java/jdk1.8.0_45/bin/javaw.exe
-vmargs
-Dosgi.requiredJavaVersion=1.6
-Xms40m
-Xmx512m



Error message that I am getting is:

Java is installed is installed in following part:
C:\Program Files (x86)\Java

Eclipse is in F:\ {drive}

Please help me guys. I am noob here.

I am trying to learn Selenium automation testing. This is my requiremet.
  • Attachment: Error_Msg.png
    (Size: 19.73KB, Downloaded 104 times)
Re: Getting Error message while starting Eclipse. [message #1693499 is a reply to message #1693494] Fri, 24 April 2015 14:43 Go to previous messageGo to next message
Nitin Dahyabhai is currently offline Nitin DahyabhaiFriend
Messages: 3840
Registered: July 2009
Senior Member

You have a 64-bit Eclipse with 32-bit versions of Java. They have to match. It's also mentioned in https://www.eclipse.org/forums/index.php/t/198527/ .

Nitin Dahyabhai
Eclipse Web Tools Platform
Re: Getting Error message while starting Eclipse. [message #1693553 is a reply to message #1693494] Sat, 25 April 2015 04:40 Go to previous message
Russell Bateman is currently offline Russell BatemanFriend
Messages: 3798
Registered: July 2009
Location: Provo, Utah, USA
Senior Member

On 04/24/2015 08:42 AM, Somen Singh wrote:
> Hi All,
>
> I went through the post here but still could not find myself comfortable.
>
> I installed an eclipse i.e eclipse-java-luna-SR2-win32-x86_64
> Java versions:
> I have multiple versions installed.
> 1. jdk1.8.0_45
> 2. jre1.8.0_40
> 3. jre1.8.0_45
>
> I tried adding the -vm into eclipse.ini file but still no help.
>
> My eclipse.ini file looks like this:
>
> -startup
> plugins/org.eclipse.equinox.launcher_1.3.0.v20140415-2008.jar
> --launcher.library
> plugins/org.eclipse.equinox.launcher.win32.win32.x86_64_1.1.200.v20150204-1316
> -product
> org.eclipse.epp.package.java.product
> --launcher.defaultAction
> openFile
> --launcher.XXMaxPermSize
> 256M
> -showsplash
> org.eclipse.platform
> --launcher.XXMaxPermSize
> 256m
> --launcher.defaultAction
> openFile
> --launcher.appendVmargs
>
> -vm
> C:/Program Files (x86)/Java/jdk1.8.0_45/bin/javaw.exe
> -vmargs
> -Dosgi.requiredJavaVersion=1.6
> -Xms40m
> -Xmx512m
>
>
>
> Error message that I am getting is:
>
> Java is installed is installed in following part:
> C:\Program Files (x86)\Java
>
> Eclipse is in F:\ {drive}
>
> Please help me guys. I am noob here.
>
> I am trying to learn Selenium automation testing. This is my requiremet.
>

Why would you try to run a 64-bit Eclipse using a 32-bit JRE?
Previous Topic:Custom Look and Feel
Next Topic:Glassfish 4 on Eclipse
Goto Forum:
  


Current Time: Thu Sep 24 11:27:28 GMT 2020

Powered by FUDForum. Page generated in 0.02882 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top