Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » Graphiti » Local build with buckminster
Local build with buckminster [message #1691102] Thu, 02 April 2015 10:34 Go to next message
Krisztian Koncz is currently offline Krisztian KonczFriend
Messages: 31
Registered: September 2014
Location: Budapest
Member

Dear Michael!

Can you give me some instructions to perform a local build with buckminster?

Best regards,
Krisztian
Re: Local build with buckminster [message #1691149 is a reply to message #1691102] Thu, 02 April 2015 14:52 Go to previous messageGo to next message
Michael Wenz is currently offline Michael WenzFriend
Messages: 1894
Registered: July 2009
Location: Walldorf, Germany
Senior Member
Krisztian,

hm, that's a difficult story...

Actually, I never got that to work for me, because my office is located
behind a firewall that allows only http communication via a proxy to the
outside. In the beginning I tried to set up a local build, but that did
never work for me. In the end I got used to simply relying on the Hudson
execution of the build, also because the UI test need quite some time during
that no other things can be done on the PC.

Basically the changes needed for a local build as far as I remember are to
provide a different build.properties file (local.properties is still part of
the releng project and should be usable probably with some adaptations...).
The content of that file is a set of property definitions that are applied
in the build script when calling Buckminster. That happens in the shell
script on Hudson, see
https://hudson.eclipse.org/graphiti/job/graphiti.gerrit/configure .

Exchanging the file there would be the first step to go. Not sure if that
will work though.

Michael
Re: Local build with buckminster [message #1691199 is a reply to message #1691149] Fri, 03 April 2015 09:51 Go to previous messageGo to next message
Krisztian Koncz is currently offline Krisztian KonczFriend
Messages: 31
Registered: September 2014
Location: Budapest
Member

Thanks for your quick response.

I have no acces to the linked script, so I try to figure it out from the console log. Succesfully build the javadoc, but the site.p2.zip action throw a NPE to me. If is succeed, i will write the neccessary steps, to local build.

Best regards,
Krisztian
Re: Local build with buckminster [message #1691747 is a reply to message #1691199] Thu, 09 April 2015 12:59 Go to previous message
Michael Wenz is currently offline Michael WenzFriend
Messages: 1894
Registered: July 2009
Location: Walldorf, Germany
Senior Member
Somehow the extended read permission for anonymous users had vanished. I
added that back to the job, now you should be able to access the
configuration and see the script.

Do you have details on the NPE?

Michael

"Krisztian Koncz" schrieb im Newsbeitrag
news:mflnrf$5gs$1@xxxxxxxxe.org...

Thanks for your quick response.

I have no acces to the linked script, so I try to figure it out from the
console log. Succesfully build the javadoc, but the site.p2.zip action throw
a NPE to me. If is succeed, i will write the neccessary steps, to local
build.

Best regards,
Krisztian
Previous Topic:Hide create feature of pattern from palette
Next Topic:Weird code in FeatureExecutionHandler
Goto Forum:
  


Current Time: Thu Jul 19 09:35:50 GMT 2018

Powered by FUDForum. Page generated in 0.02155 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top