Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » EMF Parsley » Can't create a Parsley Project(New project creation wizard fails)
Can't create a Parsley Project [message #1690611] Sun, 29 March 2015 22:37 Go to next message
John Conlon is currently offline John ConlonFriend
Messages: 35
Registered: July 2009
Member
When attempting to create a Emf Parsley Dsl based Project the project wizard I get a Problem Opening Wizard Dialog with the message:

The selected wizard could not be started.
org/eclipse/xtext/xtype/XtypeFactory
(java.lang.NoClassDefFoundError: org/eclipse/xtext/xtype/XtypeFactory)

Running on a brand newly installed Eclipse Modeling Tools
Version: Luna Service Release 2 (4.4.2)
Build id: 20150219-0600
Emf Parsley 0.3.0.v20150220-0847
which I installed from the Parsley update site.

Fix was to install the latest Xtext. Should n't the install not require and install it in the first place so it doesn't have to be done manually?




Re: Can't create a Parsley Project [message #1690716 is a reply to message #1690611] Mon, 30 March 2015 19:00 Go to previous messageGo to next message
Lorenzo Bettini is currently offline Lorenzo BettiniFriend
Messages: 1751
Registered: July 2009
Location: Firenze, Italy
Senior Member
On 30/03/2015 00:37, John Conlon wrote:
> When attempting to create a Emf Parsley Dsl based Project the project
> wizard I get a Problem Opening Wizard Dialog with the message:
>
> The selected wizard could not be started.
> org/eclipse/xtext/xtype/XtypeFactory
> (java.lang.NoClassDefFoundError: org/eclipse/xtext/xtype/XtypeFactory)
>
> Running on a brand newly installed Eclipse Modeling Tools
> Version: Luna Service Release 2 (4.4.2)
> Build id: 20150219-0600
> Emf Parsley 0.3.0.v20150220-0847
> which I installed from the Parsley update site.
> Fix was to install the latest Xtext. Should n't the install not require
> and install it in the first place so it doesn't have to be done manually?

Hi

actually it should automatically install all the Xtext requirements;
which version of Parsley have you tried to install and which update site
have you used? Which Parsley features have you installed? We have
recently released the first official version 0.3.0 and it should install
all the requirements.

cheers
Lorenzo

--
Lorenzo Bettini, PhD in Computer Science, DI, Univ. Torino
HOME: http://www.lorenzobettini.it
Xtext Book:
http://www.packtpub.com/implementing-domain-specific-languages-with-xtext-and-xtend/book
Re: Can't create a Parsley Project [message #1690736 is a reply to message #1690716] Mon, 30 March 2015 22:44 Go to previous messageGo to next message
John Conlon is currently offline John ConlonFriend
Messages: 35
Registered: July 2009
Member
Features I installed:
Emf Parsley	0.3.0.v20150220-0847	org.eclipse.emf.parsley.feature.feature.group
  Emf Parsley CDO	0.3.0.v20150220-0847	org.eclipse.emf.parsley.cdo.feature.feature.group	
  Emf Parsley CDO Developer Resources	0.3.0.v20150220-0847	org.eclipse.emf.parsley.cdo.feature.source.feature.group	Eclipse 
  Emf Parsley Developer Resources	0.3.0.v20150220-0847	org.eclipse.emf.parsley.feature.source.feature.group	
  Emf Parsley DSL	0.3.0.v20150220-0847	org.eclipse.emf.parsley.dsl.feature.feature.group
  Emf Parsley DSL Developer Resources	0.3.0.v20150220-0847	org.eclipse.emf.parsley.dsl.feature.source.feature.group
  Emf Parsley Examples	0.3.0.v20150220-0847	org.eclipse.emf.parsley.examples.feature.feature.group
  Emf Parsley Examples Developer Resources 	0.3.0.v20150220-0847	org.eclipse.emf.parsley.examples.feature.source.feature.group
  Emf Parsley SDK	0.3.0.v20150220-0847	org.eclipse.emf.parsley.sdk.feature.group
  Emf Parsley SDK Developer Resources	0.3.0.v20150220-0847	org.eclipse.emf.parsley.sdk.source.feature.group	

Update Site: Originally used the ".../emf-parsley/updates/0.3" noticed a problem adding the project. Then I tried:
Parsley All updates ".../emf-parsley/updates/" still had a problem so I manually provisioned the Xtext and after that I could add a new parsley project.

I have not tried it with a new installation of Eclipse since I encountered it to reproduce the problem. Perhaps it was just a strange p2 anomolie??
Re: Can't create a Parsley Project [message #1690771 is a reply to message #1690736] Tue, 31 March 2015 07:33 Go to previous messageGo to next message
Lorenzo Bettini is currently offline Lorenzo BettiniFriend
Messages: 1751
Registered: July 2009
Location: Firenze, Italy
Senior Member
And you previously added
http://download.eclipse.org/modeling/tmf/xtext/updates/composite/releases/
as an update site as described here
https://www.eclipse.org/emf-parsley/download.html, haven't you?

Has the checkbox "Contact all update sites..." been checked?

cheers
Lorenzo

--
Lorenzo Bettini, PhD in Computer Science, DI, Univ. Torino
HOME: http://www.lorenzobettini.it
Xtext Book:
http://www.packtpub.com/implementing-domain-specific-languages-with-xtext-and-xtend/book
Re: Can't create a Parsley Project [message #1691056 is a reply to message #1690771] Wed, 01 April 2015 22:51 Go to previous messageGo to next message
John Conlon is currently offline John ConlonFriend
Messages: 35
Registered: July 2009
Member
Both sites were added per instructions:

Xtext Updates http://download.eclipse.org/modeling/tmf/xtext/updates/composite/releases/ Enabled
Parsley All updates http://download.eclipse.org/emf-parsley/updates/ Enabled

Believe the checkbox was enabled, but not sure. Besides either way if the dependencies are set for the packages than it should NOT install them if it can't find the deps. Right?

Have not gone back and confirmed this issue with a new install - perhaps this was a p2 anomolie??
Re: Can't create a Parsley Project [message #1691069 is a reply to message #1691056] Thu, 02 April 2015 06:26 Go to previous message
Lorenzo Bettini is currently offline Lorenzo BettiniFriend
Messages: 1751
Registered: July 2009
Location: Firenze, Italy
Senior Member
On 02/04/2015 00:52, John Conlon wrote:
> Both sites were added per instructions:
>
> Xtext Updates
> http://download.eclipse.org/modeling/tmf/xtext/updates/composite/releases/
> Enabled
> Parsley All updates
> http://download.eclipse.org/emf-parsley/updates/ Enabled
>
> Believe the checkbox was enabled, but not sure. Besides either way if
> the dependencies are set for the packages than it should NOT install
> them if it can't find the deps. Right?

yes, you're right

> Have not gone back and confirmed this issue with a new install - perhaps
> this was a p2 anomolie??

it could have been an anomaly... I'll check that myself with a new install

cheers
Lorenzo

--
Lorenzo Bettini, PhD in Computer Science, DI, Univ. Torino
HOME: http://www.lorenzobettini.it
Xtext Book:
http://www.packtpub.com/implementing-domain-specific-languages-with-xtext-and-xtend/book
Previous Topic:Executing RecordingCommand using InjectableAdapterFactoryEditingDomain
Next Topic:Add a column to a Table
Goto Forum:
  


Current Time: Tue Oct 16 03:12:38 GMT 2018

Powered by FUDForum. Page generated in 0.02616 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top