Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » C / C++ IDE (CDT) » Cannot use Remote Debugging in Eclipse CDT Luna with Beaglebone black
icon12.gif  Cannot use Remote Debugging in Eclipse CDT Luna with Beaglebone black [message #1638882] Fri, 27 February 2015 10:42 Go to next message
Raj Bharath RB is currently offline Raj Bharath RBFriend
Messages: 1
Registered: February 2015
Junior Member
Hi guys,

I am newbie and am facing problem with remote debugging in both automatic and manual remote launch while I am able to build project in Eclipse and execute it in my Beaglebone black Rev C. I have gone through many posts but nothing worked out after several days of trying.

I have installed Eclipse CDT Luna in Windows 7 (64 bit) PC and debian wheezy (dated 2014-05-14) in BBB. Kernel version is 3.8.13-bone50. I followed the link (Http link: jkuhlm.bplaced.net/hellobone/). As in the last part of step 7, when I configure 'Run configurations' to execute the binary in BBB by creating new configuration under 'C/C++ Remote application', 'hellobone Debug'comes in default. So, I had to change the name as 'hellobone Default' and make sure the field 'C/C++ Application' has "Debug/TestARM5" or else it says that program does not exist. But in the end, I am able to run the file successfully in the BBB as the output in the link.

1) Next is the Automatic Remote Debugging. I followed the step 8 in the link and when I debug, I get the following output in the console:

echo $PWD'>'

chmod ugo+x /home/debian/BBBTest/TestARM5;gdbserver :2345 /home/debian/BBBTest/TestARM5;exit

root@beaglebone:~#
echo $PWD'>'
/root>
root@beaglebone:~#
root@beaglebone:~# chmod ugo+x /home/debian/BBBTest/TestARM5;gdbserver :2345 /ho

me/debian/BBBTest/TestARM5;exit
logout



Also a dialog box mentioning that "Could not start gdbserver on the remote host. See console output for more details." Also, I could find gdbserver installed in BBB and also I gave "/usr/bin/gdbserver" in the gdbserver settings of the Debugger in Eclipse but I got the same error.


2) Then I tried the Manual Remote launch as in the Figure 3 of the link ( Http link: hertaville.com/2013/01/11/remote-debugging/) eventhough it is for Rasperry PI.

I typed "sudo gdbserver 192.168.1.36:12345 /home/debian/BBBTest/hellobone" in the Eclipse terminal and the process did not create as below.
(where 192.168.1.36 is PC IP address)

root@beaglebone:/# sudo gdbserver 192.168.1.36:12345 /home/debian/BBBTest/hellobone
root@beaglebone:/#


Also tried the command sudo gdbserver 192.168.1.36:12345 hellobone and nothing happened. Then, I changed the debugger into Manual Remote Debugging launcher with settings similar to Figure 7 of the above link eventhough the prior gdbserver process was not created as mentioned above and I got the below error I think this is due to the non-creation of the prior gdbserver process .

Error in final launch sequence
Failed to execute MI command:
-target-select remote 192.168.7.2:9999
Error message from debugger back end:192.168.7.2:9999: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond.


Also, I got the same problem in my Debian wheezy OS installed in my PC where the gdbserver process also was not able to create.I am stuck in this for several days and I hope someone can help me solve this.. Many Thanks!!

Regards,
Raj
Re: Cannot use Remote Debugging in Eclipse CDT Luna with Beaglebone black [message #1692981 is a reply to message #1638882] Tue, 21 April 2015 04:51 Go to previous messageGo to next message
Rakesh Kabade is currently offline Rakesh KabadeFriend
Messages: 2
Registered: April 2015
Junior Member
Hi, Even i am getting same problem trying to figure out. in trouble
Re: Cannot use Remote Debugging in Eclipse CDT Luna with Beaglebone black [message #1737693 is a reply to message #1638882] Tue, 12 July 2016 04:57 Go to previous message
chaitanya reddy is currently offline chaitanya reddyFriend
Messages: 1
Registered: July 2016
Junior Member
any update on this?? plzz post progress because here also facing same problem
Previous Topic:Arduino plugin serial problems
Next Topic:Run Configuration with Quoted Arguments
Goto Forum:
  


Current Time: Sat Jan 20 05:31:05 GMT 2018

Powered by FUDForum. Page generated in 0.02414 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software