Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse Bundle Recipes » Apache catalina springsource bundle for Apache Tomcat v6.0.43(Which version of Apache catalina springsource bundle has security vulnerabilities fixed)
Apache catalina springsource bundle for Apache Tomcat v6.0.43 [message #1638489] Fri, 27 February 2015 06:26 Go to next message
Raghavendra Neelekani is currently offline Raghavendra NeelekaniFriend
Messages: 3
Registered: February 2015
Junior Member
I have a java application where I use Apache catalina springsource bundle (com.springsource.org.apache.catalina.springsource-6.0.20.S2-r5956.jar) to configure and start tomcat. Now I have to use tomcat of latest version which has security vulnerabilities issued fixed. Looking at Apache Tomcat website, they have released latest version of tomcat 6.0.43 where they have fixed many of the security vulnerabilities. But since I use com.springsource.org.apache.catalina.springsource-6.0.20.S2-r5956.jar for catalina implementation, the latest release of Apache catalina springsource bundle is com.springsource.org.apache.catalina.springsource v6.0.32.

My questions are
1) What is the apache tomcat version matches to com.springsource.org.apache.catalina.springsource v6.0.32. Does it match Apache Tomcat v6.0.32 ?
2) I don't see com.springsource.org.apache.catalina.springsource bundle for version 6.0.43. What is the plan for springsource to release bundle for version 6.0.43 ?
3) For now, which version of apache tomcat catalina springsource bundle should I use which has all the security vulnerabilities fixed ?

Thanks
Raagu
Re: Apache catalina springsource bundle for Apache Tomcat v6.0.43 [message #1691752 is a reply to message #1638489] Thu, 09 April 2015 13:41 Go to previous message
Gunnar Wagenknecht is currently offline Gunnar WagenknechtFriend
Messages: 485
Registered: July 2009
Location: San Francisco ✈ Germany
Senior Member

Hi Raagu,

There is no recipe available for Tomcat. But it's possible to contribute one.

Please have a look at: https://github.com/eclipse/ebr

-Gunnar
Previous Topic:Scope and Status of the EBR Project?
Next Topic:EBR now at GitHub
Goto Forum:
  


Current Time: Mon Oct 23 17:30:22 GMT 2017

Powered by FUDForum. Page generated in 0.02137 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software