Installation and migration

Subversive distribution consists of two parts - Subversive plug-in and Subversive SVN Connectors. Both parts are required in order to work with Subversive. Subversive plug-in is provided under the terms and conditions of the Eclipse Public License Version 1.0 ("EPL"). A copy of the EPL is available at Subversive SVN Connectors are external libraries with their own licenses, which are distributed from external location at

In order to install Subversive you should install Subversive plug-in and at least one of Subversive SVN connectors, such as native JavaHL connector or pure Java SVN Kit connector (please note, that we provide win32-compatible native libraries only, binaries for other platforms you need to install by yourself). Subversive plug-in and Subversive SVN Connectors are distributed from different update sites on different locations, so you should point two update sites in update manager if you use Eclipse version older than 3.5.

Installation and update process

Installation and update process is simple and straightforward. You can find step-by-step process descriptions in Installation instructions and in Update instructions.

Also please note that there is no way of migration from the Subversive 1.1.x since the latest plug-in version doesn't work with Eclise IDE versions older than 3.4 and Subversive 1.1.x does not support Eclipse 3.3 or higher either.


This version requires Eclipse 3.4 and doesn't support previous versions of Eclipse IDE. You can see full list of requirements in 'Requirements' topic.

If you have some questions on Subversive versions refer to Versions and compatibility FAQ section.