Skip to main content

Project Plan For Eclipse Project, version 4.1

Introduction

Last revised 16:00 ET December 22, 2010.

Please send comments about this plan to the eclipse-dev@eclipse.org developer mailing list.

This document lays out the feature and API set for the next feature release of the Eclipse SDK after 4.0, designated release 4.1. This release is occurring simultaneously with the 3.7 release, code-named indigo. The 3.7 release is a mature platform release, while the 4.1 release includes early versions of the next generation platform and represents the long term direction for platform client UI technology. See the 3.7 release plan for further details on the 3.7 release.

Plans do not materialize out of nowhere, nor are they entirely static. To ensure the planning process is transparent and open to the entire Eclipse community, we (the Eclipse Project PMC) post plans in an embryonic form and revise them throughout the release cycle.

The first part of the plan deals with the important matters of release deliverables, release milestones, target operating environments, and release-to-release compatibility. These are all things that need to be clear for any release, even if no features were to change.

The remainder of the plan consists of plan items for all of the sub-projects under the top level Eclipse Project. Each plan item covers a feature or API that is to be added to the Eclipse Project deliverables, or some aspect of the Eclipse Project that is to be improved. Each plan item has its own entry in the Eclipse bugzilla database, with a title and a concise summary (usually a single paragraph) that explains the work item at a suitably high enough level so that everyone can readily understand what the work item is without having to understand the nitty-gritty detail.

Not all plan items represent the same amount of work; some may be quite large, others, quite small. Some plan items may involve work that is localized to a single component; others may involve coordinated changes to several components; other may pervade the entire SDK. Although some plan items are for work that is more pressing than others, the plan items appear in no particular order.

With the previous release as the starting point, this is the plan for how we will enhance and improve it. Fixing bugs, improving test coverage, documentation, examples, performance tuning, usability, etc. are considered routine ongoing maintenance activities and are not included in this plan unless they would also involve a significant change to the API or feature set, or involve a significant amount of work. The intent of the plan is to account for all interesting feature work.

The current status of each plan item is noted:

  • Committed plan item - A committed plan item is one that we have decided to address for the release.
  • Proposed plan item - A proposed plan item is one that we are considering addressing for the release. Although we are actively investigating it, we are not yet in a position to commit to it, or to say that we won't be able to address it. After due consideration, a proposal will either be committed or deferred.
  • Deferred plan item - A reasonable proposal that will not make it in to this release for some reason is marked as deferred with a brief note as to why it was deferred. Deferred plan items may resurface as committed plan items at a later point.

Release Deliverables

The release deliverables have the same form as the 4.0 release, namely:

  • Source code release for all Eclipse Project deliverables, available as versions tagged "R4_1" in the Eclipse Project CVS repository.
  • Eclipse SDK (runtime binary and SDK for Equinox[*], Platform, JDT, and PDE) (downloadable).
  • A p2 repository containing the Eclipse 4.1 SDK for all supported platforms.

* The Equinox Project is part of the top level RT Project. A significant portion of the Equinox deliverables are consumed and redistributed as part of the Eclipse Project's SDK, Platform, and RCP deliverables.

Table of Contents

Release Milestones

Release milestones will be occurring at roughly 6 week intervals, and will be aligned with the Indigo Simultaneous Release train as a +1 level project.

M108/09/2010
4.1M1
M209/20/2010
4.1M2
M311/01/2010
4.1M3
M412/13/2010
4.1M4
M501/31/2011
4.1M5
M603/14/2011
4.1M6 (API Freeze)
M705/02/2011
4.1M7 (Feature Freeze)

Our target is to complete 4.1 in late June 2011, in alignment with Indigo. All release deliverables will be available for download as soon as the release has been tested and validated in the target operating configurations listed below.

Dates for builds and test passes after M7 will be available in the Eclipse Indigo end-game plan, available shortly before M7 in April 2011.

Table of Contents

Target Environments

In order to remain current, each Eclipse Project release targets reasonably current operating environments.

Most of the Eclipse SDK is "pure" Java code and has no direct dependence on the underlying operating system. The chief dependence is therefore on the Java Platform itself. Portions are targeted to specific classes of operating environments, requiring their source code to only reference facilities available in particular class libraries (e.g. J2ME Foundation 1.1, J2SE 1.4, Java 5, etc).

In general, the 4.1 release of the Eclipse Project is developed on a mix of Java SE 5 and Java SE 6 VMs. As such, the Eclipse SDK as a whole is targeted at all modern, desktop Java VMs. Most functionality is available for Java SE 5 level development everywhere, and extended development capabilities are made available on the VMs that support them.

Appendix 1 contains a table that indicates the class library level required for each bundle.

There are many different implementations of the Java Platform running atop a variety of operating systems. We focus our testing on a handful of popular combinations of operating system and Java Platform; these are our reference platforms. Eclipse undoubtedly runs fine in many operating environments beyond the reference platforms we test. However, since we do not systematically test them we cannot vouch for them. Problems encountered when running Eclipse on a non-reference platform that cannot be recreated on any reference platform will be given lower priority than problems with running Eclipse on a reference platform.

Eclipse 4.1 is tested and validated on the following reference platforms (this list is updated over the course of the release cycle):

Operating System Version Hardware JRE Windowing System
Windows 7 x86 32-bit Sun Java 6 Update 17
IBM Java 6 SR8
Win32
x86 64-bit
Vista x86 32-bit
x86 64-bit
XP x86 32-bit
x86 64-bit
Red Hat Enterprise Linux 5.0 x86 32-bit Sun Java 6 Update 17
IBM Java 6 SR8
GTK
x86 64-bit
4.0 x86 64-bit
SUSE Linux Enterprise Server 11 x86 32-bit Sun Java 6 Update 17
IBM Java 6 SR8
GTK
x86 64-bit
Ubuntu Long Term Support 10.04 x86 32-bit Sun Java 6 Update 17
IBM Java 6 SR8
GTK
x86 64-bit
Apple Mac OS X 10.6 Universal 32-bit Apple Java 10.6 Update 2 Cocoa
Universal 64-bit

As stated above, we expect that Eclipse works fine on other current Java VM and OS versions but we cannot flag these as reference platforms without significant community support for testing them.

Internationalization

The Eclipse SDK is designed as the basis for internationalized products. The user interface elements provided by the Eclipse SDK components, including dialogs and error messages, are externalized. The English strings are provided as the default resource bundles.

Latin-1 and DBCS locales are supported by the Eclipse SDK on all reference platforms; BIDI locales are supported by the Eclipse SDK everywhere but on Motif.

The Eclipse SDK supports GB 18030 (level 1), the Chinese code page standard, on Windows XP and 2000, Linux/GTK and the Macintosh.

German and Japanese locales are tested.

Table of Contents

Compatibility with Previous Releases

Compatibility of Release 4.1 with 4.0

Eclipse 4.1 will be compatible with Eclipse 4.0 (and all earlier 3.x versions).

API Contract Compatibility: All new API in Eclipse SDK 4.0 was provisional. Therefore there is no contract compatibility between releases 4.0 and 4.1. However, this release includes all mature API from the 3.7 release, which is fully contract-compatible with the API in the 3.6 release, except in those areas noted in the Eclipse 3.7 Plug-in Migration Guide . Downward contract compatibility is not supported. There is no guarantee that compliance with Eclipse SDK 4.1 APIs would ensure compliance with Eclipse SDK 4.0 APIs. Refer to Evolving Java-based APIs for a discussion of the kinds of API changes that maintain contract compatibility.

Binary (plug-in) Compatibility: All new API in Eclipse SDK 4.0 was provisional. Therefore there is no binary compatibility between releases 4.0 and 4.1. However, this release includes all mature API from the 3.7 release, which is fully binary-compatible with the API in the 3.6 release, except in those areas noted in the Eclipse 3.7 Plug-in Migration Guide . Downward binary compatibility is not supported. There is no guarantee that compliance with Eclipse SDK 4.1 APIs would ensure compliance with Eclipse SDK 4.0 APIs. Refer to Evolving Java-based APIs for a discussion of the kinds of API changes that maintain binary compatibility.

Source Compatibility: All new API in Eclipse SDK 4.0 was provisional. Therefore there is no source compatibility between releases 4.0 and 4.1. However, this release includes all mature API from the 3.7 release, which is fully source-compatible with the API in the 3.6 release, except in those areas noted in the Eclipse 3.7 Plug-in Migration Guide . This means that source files written to use Eclipse SDK 4.0 APIs are unlikely to compile and run against Eclipse SDK 4.1 APIs, and vice-versa.

Workspace Compatibility: Eclipse SDK 4.1 will be upwards workspace-compatible with earlier versions of the Eclipse SDK unless noted. This means that workspaces and projects created with Eclipse SDK 4.0, 3.6 .. 3.0 can be successfully opened by Eclipse SDK 4.1 and upgraded to a 4.1 workspace. This includes both hidden metadata, which is localized to a particular workspace, as well as metadata files found within a workspace project (e.g., the .project file), which may propagate between workspaces via file copying or team repositories. Individual plug-ins developed for Eclipse SDK 4.1 should provide similar upwards compatibility for their hidden and visible workspace metadata created by earlier versions; 4.1 plug-in developers are responsible for ensuring that their plug-ins recognize metadata from earlier versions and process it appropriately. User interface session state may be discarded when a workspace is upgraded. Downward workspace compatibility is not supported. A workspace created (or opened) by a product based on Eclipse 4.1 will be unusable with a product based on an earlier version of Eclipse. Visible metadata files created (or overwritten) by Eclipse 4.1 will generally be unusable with earlier versions of Eclipse.

Non-compliant usage of API's: All non-API methods and classes, and certainly everything in a package with "internal" in its name or x-internal in the bundle manifest entry, are considered implementation details which may vary between operating environment and are subject to change without notice. Client plug-ins that directly depend on anything other than what is specified in the Eclipse SDK API are inherently unsupportable and receive no guarantees about compatibility within a single release much less with earlier releases. Refer to How to Use the Eclipse API for information about how to write compliant plug-ins.

Table of Contents

Themes and Priorities

The plan items listed below were defined according to contributor requirements and the Eclipse Themes and Priorities set forth by the Eclipse Requirements Council. Each plan item covers a feature or API that is to be added to the Eclipse Project deliverables, or some aspect of the Eclipse Project that is to be improved. Each plan item has its own entry in the Eclipse bugzilla database, with a title and a concise summary (usually a single paragraph) that explains the work item at a suitably high enough level so that everyone can readily understand what the work item entails.

Although there are three mature projects under the top-level Eclipse Project, there is a significant amount of commonality and shared effort between them. In general, many plan items involve coordinated changes to multiple components, and thus attempting to separate the items into sections based on sub-project leads to artificial distinctions between them (e.g., Platform Text vs. JDT Text, Platform Debug vs. JDT Debug, etc.). As such, this plan covers the work of all mature projects under the top level Eclipse Project.

Not all plan items represent the same amount of work; some may be quite large, others, quite small. Although some plan items are for work that is more pressing than others, the plan items appear in no particular order. See the corresponding bugzilla items for up-to-date status information on ongoing work and planned delivery milestones.

The current status of each plan item is noted:

  • Committed plan item - A committed plan item is one that we have decided to address for the release. In bugzilla, this is reflected by having a concrete target milestone assigned.
  • Proposed plan item - A proposed plan item is one that we are considering addressing for the release. Although we are actively investigating it, we are not yet in a position to commit to it, or to say that we won't be able to address it. After due consideration, a proposal will either be committed or deferred. In bugzilla, such items are reflected by having a target milestone "4.1" or "---" assigned.
  • Deferred plan item - A reasonable proposal that will not make it in to this release for some reason is marked as deferred with a brief note as to why it was deferred. Deferred plan items may resurface as committed plan items at a later point. In bugzilla, such items are reflected by having a target milestone "---" assigned.

Enterprise Ready

This work is focused on taking the rough technology of the 4.0 release and making it ready for use in interprise applications. This includes providing API, documentation, accessibility, internationalization and localization capabilities.

  • Committed

    None at this time.

  • Proposed
    • Localization support. Portions of Eclipse SDK 4.0 were not localized, and no mechanism was available for translating strings in the user interface model. We will ensure the 4.1 SDK is fully localized, including all strings contained in the UI model. [UI] (306576)
    • Compatibility and workspace migration. We will focus on ensuring all API-conforming plug-ins and applications built for Eclipse 3.7 function with minimal migration effort on the 4.1 release. In addition, we will work with projects that use platform internals to aid in transition towards using full platform API. We will also ensure we provide one-way workspace compatibility, so that workspaces saved in previous version of the Eclipse platform can be opened and migrate to the platform 4.1 workspace format. [UI] (333105)
  • Deferred

    None at this time.

Table of Contents

Appendix Execution Environment by Bundle

In the table below, the "4.1 minimum execution environment" column indicates the minimum Java class library requirements of each bundle for the 4.1 release, where the value is one of:

Entry Meaning
F1.0
J2ME Foundation 1.0 - indicates that the bundle can only be run on Foundation 1.0 or greater. Note that with the exception of some MicroEdition IO classes, Foundation 1.0 is a subset of J2SE 1.3.
F1.1
J2ME Foundation 1.1 - indicates that the bundle can only be run on Foundation 1.1 or greater. Note that with the exception of some MicroEdition IO classes, Foundation 1.1 is a subset of J2SE 1.4.
1.3
J2SE 1.3 - indicates that the bundle can only be run on JSE 1.3 or greater.
1.4
J2SE 1.4 - indicates that the bundle can only be run on JSE 1.4 or greater.
1.5
Java SE 5 - indicates that the bundle can only be run on Java SE 5 or greater.
1.6
Java SE 6 - indicates that the bundle can only be run on Java SE 6 or greater.
n/a Unknown at the time of this revision.

Table of minimum execution environments by bundle. (See also the Equinox Project plan for the execution environment requirements of bundles contributed via that project.)

Bundle

4.1
minimum
execution
environment

com.ibm.icu
F1.0
com.jcraft.jsch
1.4
javax.annotation
1.5
javax.inject
1.5
javax.xml
J2SE-1.2
org.apache.ant
J2SE-1.2
org.apache.batik.css
1.3
org.apache.batik.util
1.3
org.apache.batik.util.gui
1.3
org.apache.lucene
1.4
org.apache.lucene.analysis
1.4
org.apache.lucene.core
1.4
org.eclipse.ant.core
1.4
org.eclipse.ant.launching
1.4
org.eclipse.ant.ui
1.4
org.eclipse.compare
1.4
org.eclipse.compare.core
1.4
org.eclipse.compare.win32
1.4
org.eclipse.core.commands
F1.0
org.eclipse.core.contenttype
F1.0
org.eclipse.core.databinding
F1.1
org.eclipse.core.databinding.beans
1.4
org.eclipse.core.databinding.observable
F1.1
org.eclipse.core.databinding.property
F1.1
org.eclipse.core.expressions
F1.0
org.eclipse.core.externaltools
1.4
org.eclipse.core.filebuffers
1.4
org.eclipse.core.filesystem
1.4
org.eclipse.core.jobs
F1.0
org.eclipse.core.net
F1.1
org.eclipse.core.resources
1.5
org.eclipse.core.runtime
F1.0
org.eclipse.core.runtime.compatibility
F1.0
org.eclipse.core.runtime.compatibility.auth
F1.0
org.eclipse.core.runtime.compatibility.registry
F1.0
org.eclipse.core.variables
1.4
org.eclipse.cvs
not specified
org.eclipse.debug.core
1.4
org.eclipse.debug.ui
1.4
org.eclipse.e4.core.commands
1.5
org.eclipse.e4.core.contexts
1.5
org.eclipse.e4.core.di
1.5
org.eclipse.e4.core.di.extensions
1.5
org.eclipse.e4.core.services
F1.1
org.eclipse.e4.emf.xpath
1.5
org.eclipse.e4.ui.bindings
1.5
org.eclipse.e4.ui.css.core
1.5
org.eclipse.e4.ui.css.swt
1.5
org.eclipse.e4.ui.css.swt.theme
1.5
org.eclipse.e4.ui.di
1.5
org.eclipse.e4.ui.model.workbench
1.5
org.eclipse.e4.ui.services
1.5
org.eclipse.e4.ui.widgets
1.5
org.eclipse.e4.ui.workbench
1.5
org.eclipse.e4.ui.workbench.addons.swt
1.5
org.eclipse.e4.ui.workbench.renderers.swt
1.5
org.eclipse.e4.ui.workbench.swt
1.5
org.eclipse.e4.ui.workbench3
1.5
org.eclipse.emf.common
1.5
org.eclipse.emf.ecore
1.5
org.eclipse.emf.ecore.change
1.5
org.eclipse.emf.ecore.xmi
1.5
org.eclipse.help
F1.0
org.eclipse.help.base
1.4
org.eclipse.help.ui
1.4
org.eclipse.help.webapp
1.4
org.eclipse.jdt
not specified
org.eclipse.jdt.apt.core
1.5
org.eclipse.jdt.apt.pluggable.core
1.6
org.eclipse.jdt.apt.ui
1.5
org.eclipse.jdt.compiler.apt
1.6
org.eclipse.jdt.compiler.tool
1.6
org.eclipse.jdt.core
1.4
org.eclipse.jdt.core.manipulation
1.4
org.eclipse.jdt.debug
1.4
org.eclipse.jdt.debug.ui
1.4
org.eclipse.jdt.doc.isv
not specified
org.eclipse.jdt.doc.user
not specified
org.eclipse.jdt.junit
1.5
org.eclipse.jdt.junit.core
1.4
org.eclipse.jdt.junit.runtime
1.3
org.eclipse.jdt.junit4.runtime
1.5
org.eclipse.jdt.launching
1.4
org.eclipse.jdt.ui
1.4
org.eclipse.jface
F1.1
org.eclipse.jface.databinding
F1.0
org.eclipse.jface.text
1.4
org.eclipse.jsch.core
1.4
org.eclipse.jsch.ui
1.4
org.eclipse.ltk.core.refactoring
1.4
org.eclipse.ltk.ui.refactoring
1.4
org.eclipse.pde
1.4
org.eclipse.pde.api.tools
1.4
org.eclipse.pde.api.tools.ui
1.4
org.eclipse.pde.build
1.4
org.eclipse.pde.core
1.4
org.eclipse.pde.doc.user
not specified
org.eclipse.pde.ds.core
1.4
org.eclipse.pde.ds.ui
1.4
org.eclipse.pde.junit.runtime
1.4
org.eclipse.pde.launching
1.4
org.eclipse.pde.runtime
1.4
org.eclipse.pde.ua.core
1.4
org.eclipse.pde.ua.ui
1.4
org.eclipse.pde.ui
1.4
org.eclipse.pde.ui.templates
1.4
org.eclipse.platform
F1.0
org.eclipse.platform.doc.isv
not specified
org.eclipse.platform.doc.user
not specified
org.eclipse.rcp
not specified
org.eclipse.sdk
not specified
org.eclipse.search
1.4
org.eclipse.swt
F1.0
org.eclipse.team.core
1.4
org.eclipse.team.cvs.core
1.4
org.eclipse.team.cvs.ssh2
1.4
org.eclipse.team.cvs.ui
1.4
org.eclipse.team.ui
1.4
org.eclipse.text
1.4
org.eclipse.ui
F1.0
org.eclipse.ui.browser
1.4
org.eclipse.ui.cheatsheets
1.4
org.eclipse.ui.console
1.4
org.eclipse.ui.editors
1.4
org.eclipse.ui.externaltools
1.4
org.eclipse.ui.forms
1.4
org.eclipse.ui.ide
1.4
org.eclipse.ui.ide.application
1.4
org.eclipse.ui.intro
1.4
org.eclipse.ui.intro.universal
1.4
org.eclipse.ui.navigator
1.4
org.eclipse.ui.navigator.resources
1.4
org.eclipse.ui.net
F1.1
org.eclipse.ui.views
1.4
org.eclipse.ui.views.log
1.4
org.eclipse.ui.views.properties.tabbed
F1.0
org.eclipse.ui.win32
1.4
org.eclipse.ui.workbench
1.5
org.eclipse.ui.workbench.texteditor
1.4
org.eclipse.update.configurator
F1.0
org.hamcrest.core
1.5
org.junit
1.3
org.junit4
1.5
org.objectweb.asm
1.3
org.w3c.css.sac
F1.0
org.w3c.dom.smil
F1.0
org.w3c.dom.svg
F1.0

Table of Contents

Back to the top