Project Plan For Business Intelligence and Reporting Tools (BIRT), version 4.2.1

Introduction

This document lays out the feature and API set for the first release of the Eclipse BIRT project after 4.2, designated as BIRT 4.2 Service Release 1 (abbreviated as BIRT 4.2 SR1).

Plans do not materialize out of nowhere, nor are they entirely static. To ensure the planning process is transparent and open to the entire Eclipse community, plans are posted in an embryonic form and then revised from time to time throughout the release cycle.

The first part of the plan deals with the important matters of release deliverables, release milestones, target operating environments, and release-to-release compatibility. These are all things that need to be clear for any release, even if no features were to change.

The remainder of the plan consists of plan items for the projects under the Eclipse BIRT project. Each plan item covers a feature or API that is to be added, or some aspect that is to be improved. Each plan item has its own entry in the Eclipse bugzilla database, with a title and a concise summary(usually a single paragraph) that explains the work item at a suitably high enough level so that everyone can readily understand what the work item is without having to understand the nitty-gritty detail.

Please send comments about this draft plan to the BIRT Developer mailing list.

Release Deliverables

This release of BIRT will focus on providing the same downloads as BIRT 4.2.

Table of Contents

Release Milestones

For information about new features assigned to each milestone please refer to the bugzilla database. The bugzilla database will be updated on an ongoing basis as the plan progresses.

RC108/26/2012
4.2 SR1 RC1
RC209/04/2012
4.2 SR1 RC2
RC309/11/2012
4.2 SR1 RC3
RC409/18/2012
4.2 SR1 RC4/ Final
GA09/28/2012
Juno SR1 GA

Table of Contents

Target Environments

In order to remain current, each release of an Eclipse project targets reasonably current versions of underlying operating environments and other Eclipse projects on which it depends.

Most of Eclipse, and all of BIRT, is "pure" Java code and has no direct dependence on the underlying operating system. For BIRT, the chief dependence is on the Eclipse Platform, Graphical Editor Framework (GEF), Modeling Framework (EMF), and on the Java 2 Platform that runs it.

The Eclipse BIRT 4.2 SR1 release depends on the following compatibility stacks:

BIRT 4.2 SR1 Reference Stack for Java SE 7

  • Java SE 7
  • Eclipse Platform Runtime Binary 3.7, 3.8, 4.2
  • Graphical Editor Framework (GEF) Runtime 3.7
  • Eclipse Modeling Framework (EMF) 2.7
  • Data Tools Platform Project (DTP) 1.10
  • Web Tools Project (WTP) 3.3

BIRT 4.2 SR1 Reference Stack for Java SE 6

  • Java SE 6
  • Eclipse Platform Runtime Binary 3.7, 3.8, 4.2
  • Graphical Editor Framework (GEF) Runtime 3.7
  • Eclipse Modeling Framework (EMF) 2.7
  • Data Tools Platform Project (DTP) 1.10
  • Web Tools Project (WTP) 3.3

The Eclipse Platform and BIRT run in a variety of operating environments. Testing is focused on a handful of popular combinations of operating system and Java 2 Platform; these are our reference platforms. Eclipse BIRT undoubtedly runs fine in many operating environments beyond the reference platforms we test. However, since we do not systematically test them we cannot vouch for them. Problems encountered when running Eclipse BIRT on non-reference platforms that cannot be recreated on any reference platform will be given lower priority than problems with running Eclipse BIRT on a reference platform.

For BIRT 4.2 SR1, the project team plans to tests and validate the following reference platforms:

Eclipse BIRT Report Framework 4.2 SR1 and Eclipse BIRT RCP Report Designer 4.2 SR1 Reference Platforms
Operating system Processor architecture Window system Java SE
Microsoft Windows 7, 7 SP1 Intel x86 Win32 Oracle Java SE 6, 7
Microsoft Windows XP Intel x86 Win32 Oracle Java SE 6, 7
Red Hat Enterprise Linux 6.0, 6.1
Red Hat Enterprise Linux AS 5.0
Intel x86 GTK Oracle Java SE 6, 7

Eclipse BIRT Runtime 4.2 SR1 and Eclipse BIRT Charts 4.2 SR1 Reference Platforms
Operating system Processor architecture Window system Java SE
Microsoft Windows 7 Intel x86 Win32* Oracle Java SE 6, 7
Microsoft Windows XP Intel x86 Win32* Oracle Java SE 6, 7
Red Hat Enterprise Linux 6.0
Red Hat Enterprise Linux AS 5.0
Red Hat Enterprise Linux WS 5.0
Intel x86 GTK* Oracle Java SE 6, 7
SUSE Linux Enterprise Server 9 Intel x86 YaST* Oracle Java SE 6, 7
*Window system only required when displaying charts within SWT or SWING windows.


BIRT Application Server Reference Platform
Apache Tomcat 5.5.x, 6.0.16, 7.0.20
JBoss AS 5.0, 7.0.1
Oracle Weblogic Application Server 9.2, 10.3
IBM Websphere Application Server 6.1, 7.0, 8.0

BIRT JDBC Reference Platforms
MySQL Connector/J 3.x JDBC driver
Derby V10.5.1.1 JDBC driver
Actuate DataDirect JDBC drivers

Community Tested Operating Environments

Due to the finite resources available to the BIRT project, we would like to encourage the BIRT community to contribute to testing BIRT in operating environments other than those listed as target operating environments for the 4.2 SR1 release of BIRT and to share this information with the rest of the community. If you have been able to test BIRT in a non-targeted operating environment please take a few minutes to update this wiki page and report this information there. If you have encountered bugs during your testing, please report these in bugzilla.

Internationalization

Eclipse is designed as the basis for internationalized products. The user interface elements provided by the various Eclipse projects, including dialogs and error messages, are externalized. The English strings for BIRT are provided as the default resource bundles. Translations are provided with this release for French (fr_FR), German (de_DE), Spanish (es_ES), Japanese (ja_JP), Simplified Chinese (zh_CN), and Korean (ko_KR).

Table of Contents

Compatibility with Previous Releases

BIRT 4.2 SR1 will be compatible with earlier versions of BIRT to the greatest extent possible. The nature and scope of some of the key plan items for BIRT 4.2 SR1 are such that the only feasible solutions might break compatibility. In other regards, BIRT 4.2 SR1 will be compatible with 4.x, 3.x, 2.x and 1.x. We also aim to minimize the effort required to port an existing plug-in to the 4.2 SR1 APIs.

Compatibility of Release 4.2 SR1 with Prior Releases

BIRT 4.2 SR1 will be compatible with prior releases of BIRT unless noted otherwise. The detailed compatibility statement is listed below. In this statement, "BIRT" refers to all BIRT components: BIRT Report Framework, BIRT Runtime, and BIRT Chart SDK.

API Contract Compatibility: BIRT 4.2 SR1 will be upwards contract-compatible with BIRT prior releases except in those areas noted in the Eclipse BIRT Migration Guide. Downward contract compatibility is not supported. In other words there is no guarantee that compliance with BIRT 4.2 SR1 APIs will ensure compliance with prior BIRT release APIs. Refer to general Eclipse document on Evolving APIs for a discussion on the kinds of API changes that maintain contract compatibility.

Binary (plug-in) Compatibility: The BIRT 4.2 SR1 plug-in framework will be upwards binary-compatible with prior BIRT release plug-ins except in those areas noted in the Eclipse BIRT Migration Guide. This means that plug-ins (including extension plug-ins) for prior BIRT releases will be upwards binary-compatible with BIRT 4.2 SR1 unless noted otherwise. Downward plug-in compatibility is not supported. In other words plug-ins for BIRT 4.2 SR1 will not be usable in prior BIRT releases.

Source Compatibility: BIRT 4.2 SR1 will be upwards source-compatible with prior BIRT releases except in those areas noted in the Eclipse BIRT Migration Guide. This means that source files written to use prior BIRT release APIs will successfully compile and run against BIRT 4.2 SR1 APIs. Downward source compatibility is not supported. If source files use new BIRT APIs, they will not be usable with an earlier version of BIRT.

Report Design Compatibility: BIRT 4.2 SR1 will be upwards report design compatible with prior BIRT releases except in those areas noted in the Eclipse BIRT Migration Guide. This means that reports created with prior BIRT releases can be successfully opened by BIRT 4.2 SR1 and upgraded to the 4.2 SR1 format.

Non-compliant usage of API's: All non-API methods and classes, and certainly everything in a package with "internal" in its name, are considered implementation details which may vary between operating environment and are subject to change without notice. Client plug-ins that directly depend on anything other than what is specified in the BIRT API are inherently unsupportable and receive no guarantees about compatibility within a single release much less with an earlier releases.

Table of Contents

Themes and Priorities

BIRT 4.2 SR1 is the first maintenance release in the BIRT 4.2 release series and is intended to be narrow in scope. The 4.2 SR1 release is primarily focused on addressing critical bugs identified by the community. The list of defects targeted for resolution in BIRT 4.2 SR1 can be found in the bugzilla database at https://bugs.eclipse.org/bugs.

Table of Contents

Appendix : Help Wanted

We welcome any contributions from the community towards the BIRT project. This help can be in the form of adding new functionality to BIRT, submitting bug fixes/enhancements to the current BIRT code and testing BIRT on new platforms.
Please refer to this bugzilla query for the list of enhancements that we need help on. For more information on how you can contribute to the BIRT project, refer to How to Contribute to the BIRT Project

Table of Contents

view raw xml of project plan
from project meta-data key "projectplanurl"