OSEE - Eclipse Installation

OSEE can be installed from within Eclipse using update manager. All the user should do is point update manager to the remote or local update site. To install OSEE:

  1. Start Eclipse and select menu item 'Help > Software Updates...'

    Software Updates

  2. Select the 'Available Software' tab group and click the 'Add Site...' button.

    Update manager

  3. On the 'Add Site' dialog enter the URL to the 'Add-On' update site. The proper URL can be found on http://www.eclipse.org/osee/downloads.php. If the update site is marked as an archived site, you will need to download the archived update site to your local file system, and add the path to the 'Add-Site' dialog by using the 'Archive' button. If the update site is not marked as an archived update site then copy the URL listed in the downloads page directly into the 'Add-Site' dialog.
    • Please note that the use of the software you are about to access may be subject to third party terms and conditions and you are responsible for abiding by such terms and conditions.

    Click on the 'OK' button to store update site information.

    New update site

  4. Select the OSEE update site entry and all features listed under its category. Click the 'Install' button.

    Feature Search Result

  5. The update manager calculates dependencies and offers you a list of features to install. Select the needed ones and click the 'Next >' button.

    Features to Install

  6. Accept terms of license agreement and click the 'Finish' button in order to start the download of selected features.

    Feature License

  7. To apply installation changes click on the 'No' button and shutdown Eclipse. It is important that you don't restart Eclipse until you have completed the database initialization steps below.

    Restart dialog

  8. Before you can use OSEE you will need to install a relational database. Follow the instructions at 'Supported Databases' to complete this step.

  9. Initialize the database with default OSEE data 'Database Initialization'

  10. Setup config.ini and launch eclipse to start using OSEE 'OSEE Config & Launch'

  11. You can find different OSEE perspectives, such as Define and ATS, and views in correspondent dialogs, activated by menu items 'Window > Open Perspective > Other...' and 'Window > Show View > Other...'.

    Open Perspective Show View