Project Plan For Mylyn, version 3.4

Table of Contents


The first goal of Mylyn is to make task and context management seamlessly integrated with the Eclipse Platform by providing rich and extensible frameworks for task repository connectors, structure bridges and team support. The second goal is to provide a reference implementation of the Task-Focused UI for the Eclipse SDK. This includes structure bridges for the artifacts supported by the SDK which include Java, PDE, Ant and generic files. It also includes the Bugzilla Connector as the reference task repository implementation, and CVS integration as the reference team support. Additional features can be considered based on the availability community contributions and resources.

Release Deliverables

The Mylyn JIRA Connector has moved to Atlassian and is no longer released as part of Mylyn.

Table of Contents

Release Milestones

The plan and roadmap dates are listed in the Mylyn Calendar (view as iCal or html) and on the Eclipse project timeline.

Service Release
Service Release
Service Release (Galileo SR2)
Service Release
3.4 RC105/26/2010
Release Candidate (API and Feature Complete)
3.4 RC206/02/2010
Release Candidate
3.4 RC306/09/2010
Release Candidate (API Freeze)
3.4 RC406/16/2010
Release Candidate (Final Build)
Major Release (Helios)

Ramp Down

After RC1 is released, builds will be produced weekly until the 3.4 release. In the RC phase only bugs marked P2 or higher or severity major or higher will be fixed. APIs will not change except to address critical fixes based on integrator feedback, until RC3, at which point APIs will be frozen.

Table of Contents

Target Environments

Mylyn is designed to run on version 1.5.0 of the Java Runtime Environment, Standard Edition.

Mylyn will support the following Eclipse releases:

Support for Eclipse 3.3 has been discontinued.

Test Platforms
Operating system OS version Processor architecture Window system Java 2 Platform Eclipse Release
Manual Tests
Ubuntu Linux 9.10 x86-32 GTK Sun Java 2 Standard Edition 6.0 Eclipse 3.6 (latest milestone)
Ubuntu Linux 8.04 x86-64 GTK Sun Java 2 Standard Edition 6.0 Eclipse 3.5.2
Microsoft Windows 7 x86-64 Win32 Sun Java 2 Standard Edition 5.0 Eclipse 3.6 (latest milestone)
Apple Mac OS X 10.6 Power Cocoa Apple Java 2 Platform Standard Edition (J2SE) 6 Eclipse 3.6 (latest milestone)
Automated Tests
Ubuntu Linux 8.04 x86-64 GTK Sun Java 2 Standard Edition 6.0 Eclipse 3.6, 3.5, Eclipse 3.4


Strings in all non-incubation plug-ins and features will be externalized and available for translation through Eclipse Babel. See bug 215116 for details.

Table of Contents

Compatibility with Previous Releases

API Contract Compatibility: Mylyn 3.4 will be backward compatible with Mylyn 3.0.

Binary (plug-in) Compatibility: Mylyn 3.4 will be binary compatible with Mylyn 3.0.

Source Compatibility: Mylyn 3.4 will not by be source compatible with previous versions.

Workspace Compatibility: We intend to keep Mylyn 3.4 upwards workspace-compatible with all versions higher than Mylyn 2.0 unless noted. This means that workspaces created with Mylyn 2.0 can be successfully opened by Mylyn 3.4 and upgraded to a 3.4 workspace.

Table of Contents

Themes and Priorities

In addition to using the planned themes listed below, we need to continue prioritizing the ongoing input of our growing user community. Committers should prioritize bugs in the following order. This order need not be used if a bug contains a community contribution of a patch, in which case the quality of the patch determines the priority.

All bugs scheduled for Mylyn 3.4

Framework and API

User Interface

Table of Contents