Skip to main content

3.0.0.M01 - Release Notes

Notable improvements:

  • Supported Java SE 7 or later.
  • Embedded Apache Tomcat version 8.0.18.
  • Compatible with Equinox version Luna.

Migration from Gemini Web 2.2.5 to Gemini Web 3.0.0.M01

Bundles with changed version

  • All Apache Tomcat bundles 7.0.56.* -> 8.0.18
  • All Virgo Util bundles 3.6.0.RELEASE -> 3.6.3.RELEASE
  • org.eclipse.jdt.core.compiler.batch 3.10.0.v20140604-1726 -> 3.10.0.v20140902-0626
  • javax.annotation 1.1.0.v201108011116 -> 1.2.0.v201401042248
  • javax.el 2.2.0.v201108011116 -> 3.0.0
  • javax.persistence 2.0.4.v201112161009 -> 2.1.0.v201304241213
  • javax.servlet 3.0.0.v201103241009 -> 3.1.0
  • javax.servlet.jsp 2.2.0.v201112011158 -> 2.3.0

A full list of bugs included in this milestone is available here.

Back to the top