Chapter 3. Requirements

Gemini Blueprint 2.x binaries require JDK level 6.0 or above, and OSGi R4.2 (though R4.1 and even R4.0 might work) or above. For JDK 1.5, consider using Gemini Blueprint 1.x. For JDK 1.4, consider using Spring Dynamic Modules 1.x.

Bundles deployed for use with Gemini Blueprint should specify "Bundle-ManifestVersion: 2" in their manifest (require OSGi R4 behaviour). Note that for OSGi 4.2 specific functionality (such as the Blueprint Container), an appropriate container needs to be used.

We test against Equinox and Felix as part of our release process.