Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Equinox » Update with p2 fails in RCP app
Update with p2 fails in RCP app [message #133493] Tue, 23 June 2009 19:46 Go to previous message
Eclipse UserFriend
Originally posted by: fakemail.xyz.de

Hello,

would like to know if someone knows what I did wrong..

locally:
an older version of the rcp app

in the updatesite:
all Features I have exported by hand (the ones in the RCP app + some
with additional functionality for the app)



When trying to update. It shows that no updates are available.
Though I am able to install additional features.
Also I am able to slect the newer Version of the feature in the install
dialog. Though when trying to install it I get the following message.

Your original request has been modified.
"Baseclient Feature" is already installed, so an update will be
performed instead.
Cannot complete the install because of a conflicting dependency.
Software being installed: Baseclient Feature 1.1.1
(eu.jucy.feature.baseclient.feature.group 1.1.1)
Software currently installed: jucy 1.0.50 (eu.jucy.product1.product
1.0.50)
Only one of the following can be installed at once:
Baseclient Feature 1.1.1 (eu.jucy.feature.baseclient.feature.jar 1.1.1)
Baseclient Feature 1.0.50 (eu.jucy.feature.baseclient.feature.jar
1.0.50)
Cannot satisfy dependency:
From: Baseclient Feature 1.0.50
(eu.jucy.feature.baseclient.feature.group 1.0.50)
To: eu.jucy.feature.baseclient.feature.jar [1.0.50]
Cannot satisfy dependency:
From: Baseclient Feature 1.1.1
(eu.jucy.feature.baseclient.feature.group 1.1.1)
To: eu.jucy.feature.baseclient.feature.jar [1.1.1]
Cannot satisfy dependency:
From: jucy 1.0.50 (eu.jucy.product1.product 1.0.50)
To: eu.jucy.feature.baseclient.feature.group [1.0.50]



What did I do wrong?

Christian
 
Read Message
Read Message
Read Message
Read Message
Read Message
Previous Topic:ServletContext real path in Jetty.
Next Topic:P2 Update Site - set http headers in request
Goto Forum:
  


Current Time: Tue Sep 26 03:56:53 GMT 2017

Powered by FUDForum. Page generated in 0.01940 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software