Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » EMF » Error: "annotations are only available if source level is 1.5"
Error: "annotations are only available if source level is 1.5" [message #656051] Wed, 23 February 2011 16:46 Go to previous message
Neil Bartlett is currently offline Neil Bartlett
Messages: 93
Registered: July 2009
Member
Hi, I'm having more adventures with EMF in a non-plugin project.

After generating my model code for the first time, I am unable to reload
the genmodel from the annotated Java. Looking in the error log, I
noticed this error:

"A problem was detected while parsing a Java fileLine 60: Syntax
error, annotations are only available if source level is 1.5
Line 105: Syntax error, annotations are only available if source level
is 1.5"

However the project definitely is at source level 1.5. From my
..settings/org.eclipse.jdt.core.prefs:

org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.5
org.eclipse.jdt.core.compiler.compliance=1.5
org.eclipse.jdt.core.compiler.source=1.5

And from my .classpath:

<classpathentry kind="con"
path=" org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.inte rnal.debug.ui.launcher.StandardVMType/J2SE-1.5 "/>

So, where is EMF getting the idea that this project is not at source
level 1.5? And why does this problem only happen after I generate model
code for the first time?

Many thanks,
Neil
 
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Previous Topic:[CDO] 'Decoration Calculation' error using CDO Sessions View
Next Topic:Dynamic Model: invalid classifier
Goto Forum:
  


Current Time: Sat Jul 26 03:16:47 EDT 2014

Powered by FUDForum. Page generated in 0.02323 seconds