Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Equinox » Headless build fails after upgrading to Helios
Headless build fails after upgrading to Helios [message #543271] Mon, 28 June 2010 21:45 Go to previous message
Eric Jain is currently offline Eric JainFriend
Messages: 266
Registered: July 2009
Senior Member
None of the bundles listed below were required to build an RCP application prior to the upgrade.

[p2.director] An error occurred while collecting items to be installed
[p2.director] session context was:(profile=profile, phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=).
[p2.director] No repository found containing: osgi.bundle,org.apache.ant,1.7.1.v20100518-1145
[p2.director] No repository found containing: osgi.bundle,org.eclipse.ant.core,3.2.200.v20100427
[p2.director] No repository found containing: osgi.bundle,org.eclipse.compare,3.5.100.I20100526-0800
[p2.director] No repository found containing: osgi.bundle,org.eclipse.compare.core,3.5.100.I20100526-0800
[p2.director] No repository found containing: osgi.bundle,org.eclipse.core.runtime.compatibility.auth,3.2.200.v20100517
[p2.director] No repository found containing: osgi.bundle,org.eclipse.debug.core,3.6.0.v20100519
[p2.director] No repository found containing: osgi.bundle,org.eclipse.equinox.p2.operations,2.0.0.v20100510
[p2.director] No repository found containing: osgi.bundle,org.eclipse.equinox.security.ui,1.0.200.v20100503
[p2.director] No repository found containing: osgi.bundle,org.eclipse.jdt.core,3.6.0.v_A58
[p2.director] No repository found containing: osgi.bundle,org.eclipse.jdt.debug,3.6.0.v20100526
[p2.director] No repository found containing: osgi.bundle,org.eclipse.team.core,3.5.100.I20100527-0800
[p2.director] No repository found containing: osgi.bundle,org.eclipse.ui.editors,3.6.0.v20100520-0800
[p2.director] No repository found containing: osgi.bundle,org.eclipse.ui.ide,3.6.0.I20100601-0800
[p2.director] No repository found containing: osgi.bundle,org.eclipse.ui.workbench.texteditor,3.6.0.v20100520-0800
[java] A problem occured while invoking the director.


When I open the Dependencies tab in the Product editor and execute the Validate command I get "no problems were detected".

When I run the build with -verbose passed to org.eclipse.ant.core.antRunner, I get this exception:

[java] /opt/eclipse/plugins/org.eclipse.pde.build_3.6.0.v20100603/scripts/genericTargets.xml:236: A problem occured while invoking the director.
[java] 	at org.apache.tools.ant.ProjectHelper.addLocationToBuildException(ProjectHelper.java:508)
[java] 	at org.apache.tools.ant.taskdefs.Ant.execute(Ant.java:418)
[java] 	at org.apache.tools.ant.taskdefs.CallTarget.execute(CallTarget.java:105)
[java] 	at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:288)
[java] 	at sun.reflect.GeneratedMethodAccessor4.invoke(Unknown Source)
[java] 	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
[java] 	at java.lang.reflect.Method.invoke(Method.java:597)
[java] 	at org.apache.tools.ant.dispatch.DispatchUtils.execute(DispatchUtils.java:106)
[java] 	at org.apache.tools.ant.Task.perform(Task.java:348)
[java] 	at org.apache.tools.ant.Target.execute(Target.java:357)
[java] 	at org.apache.tools.ant.Target.performTasks(Target.java:385)
[java] 	at org.apache.tools.ant.Project.executeSortedTargets(Project.java:1337)
[java] 	at org.apache.tools.ant.Project.executeTarget(Project.java:1306)
[java] 	at org.apache.tools.ant.helper.DefaultExecutor.executeTargets(DefaultExecutor.java:41)
[java] 	at org.eclipse.ant.internal.core.ant.EclipseDefaultExecutor.executeTargets(EclipseDefaultExecutor.java:32)
[java] 	at org.apache.tools.ant.Project.executeTargets(Project.java:1189)
[java] 	at org.eclipse.ant.internal.core.ant.InternalAntRunner.run(InternalAntRunner.java:662)
[java] 	at org.eclipse.ant.internal.core.ant.InternalAntRunner.run(InternalAntRunner.java:534)
[java] 	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
[java] 	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
[java] 	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
[java] 	at java.lang.reflect.Method.invoke(Method.java:597)
[java] 	at org.eclipse.ant.core.AntRunner.run(AntRunner.java:513)
[java] 	at org.eclipse.ant.core.AntRunner.start(AntRunner.java:600)
[java] 	at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
[java] 	at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
[java] 	at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
[java] 	at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:369)
[java] 	at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)
[java] 	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
[java] 	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
[java] 	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
[java] 	at java.lang.reflect.Method.invoke(Method.java:597)
[java] 	at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:619)
[java] 	at org.eclipse.equinox.launcher.Main.basicRun(Main.java:574)
[java] 	at org.eclipse.equinox.launcher.Main.run(Main.java:1407)
[java] 	at org.eclipse.equinox.launcher.Main.main(Main.java:1383)


Any suggestions how I can figure out what is going on here?
 
Read Message
Read Message
Read Message
Read Message
Previous Topic:How to use P2 to install simultaneously multiple versions of the same feature
Next Topic:How to secure OSGi. How to have secured console?
Goto Forum:
  


Current Time: Sat Nov 27 06:01:29 GMT 2021

Powered by FUDForum. Page generated in 0.01843 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top