Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Equinox » p2 error: "Unable to read repository"
p2 error: "Unable to read repository" [message #485890] Tue, 15 September 2009 13:08 Go to previous message
Eclipse User
Originally posted by: valy.xamance.com

Hi

I'm trying to add auto-update capabilities to our RCP-based software
using the p2 system. I followed the "Adding Self-Update to an RCP
Application" tutorial [1] and used the latest version of P2Util.java
from the CVS repository [2]. The software has a simple test plugin that
I would like to update and everything is packaged as a feature.

By copying the plugins dependencies from the prestartupdate example,
I've managed to export my application and make it connect successfully
to the HTTP repository listed in my p2.inf file, using the fully
qualified action
"org.eclipse.equinox.p2.touchpoint.eclipse.addRepository" [3]. As
requested on this page [4], the "org.eclipse.ecf.provider.filetransfer"
plugin is included.


In my server logs, I can see the following lines:

192.168.5.10 - - [15/Sep/2009:11:54:03 +0200] "HEAD
/UpdateSite/content.jar HTTP/1.1" 200 - "-" "Jakarta
Commons-HttpClient/3.1"
192.168.5.10 - - [15/Sep/2009:11:54:03 +0200] "GET
/UpdateSite/content.jar HTTP/1.1" 200 26169 "-" "Jakarta
Commons-HttpClient/3.1"


However, on the client side this error occurs:

Checking repository http://192.168.0.103/UpdateSite
ERROR:Unable to read repository at
http://192.168.0.103/UpdateSite/content.jar.
TRACE:
org.eclipse.equinox.internal.p2.metadata.repository.CacheMan ager.updateCache(CacheManager.java:416)

org.eclipse.equinox.internal.p2.metadata.repository.CacheMan ager.createCache(CacheManager.java:195)

org.eclipse.equinox.internal.provisional.spi.p2.metadata.rep ository.SimpleMetadataRepositoryFactory.getLocalFile(SimpleM etadataRepositoryFactory.java:60)

org.eclipse.equinox.internal.provisional.spi.p2.metadata.rep ository.SimpleMetadataRepositoryFactory.validateAndLoad(Simp leMetadataRepositoryFactory.java:99)

org.eclipse.equinox.internal.provisional.spi.p2.metadata.rep ository.SimpleMetadataRepositoryFactory.load(SimpleMetadataR epositoryFactory.java:87)

org.eclipse.equinox.internal.p2.metadata.repository.Metadata RepositoryManager.factoryLoad(MetadataRepositoryManager.java :54)

org.eclipse.equinox.internal.p2.repository.helpers.AbstractR epositoryManager.loadRepository(AbstractRepositoryManager.ja va:669)

org.eclipse.equinox.internal.p2.repository.helpers.AbstractR epositoryManager.loadRepository(AbstractRepositoryManager.ja va:617)

org.eclipse.equinox.internal.p2.metadata.repository.Metadata RepositoryManager.loadRepository(MetadataRepositoryManager.j ava:92)

org.eclipse.equinox.internal.p2.metadata.repository.Metadata RepositoryManager.loadRepository(MetadataRepositoryManager.j ava:88)

[...]


After reading this post [5], I've added all of the
"org.eclipse.equinox.p2.*" plugins minus the sources ones but without
more luck.

I've tried to change the repositories in the p2.inf file and used those
of Galileo, but the error is the same ("Unable to read repository at
http://download.eclipse.org/releases/galileo/content.jar").

Finally I checked the behaviour of the prestartupdate example, and it
appears that the same error occurs with both repositories (mine and
galileo).

So what did I did wrong? I checked every documentation I could find on
the net and didn't find the answer. This message on the list [6] looks a
bit similar but the response links to a thread problem which I don't
have (yet).


Thanks in advance,
Maxime


[1]
http://wiki.eclipse.org/Equinox/p2/Adding_Self-Update_to_an_ RCP_Application
[2]
http://dev.eclipse.org/viewcvs/index.cgi/org.eclipse.equinox /p2/examples/org.eclipse.equinox.p2.examples.rcp.prestartupd ate/src/org/eclipse/equinox/p2/examples/rcp/prestartupdate/P 2Util.java?root=RT_Project&view=markup

[3]
http://dev.eclipse.org/newslists/news.eclipse.technology.equ inox/msg06476.html

[4] http://www.toedter.com/blog/?p=24#comment-5652
[5]
http://dev.eclipse.org/newslists/news.eclipse.technology.equ inox/msg06450.html

[6]
http://dev.eclipse.org/newslists/news.eclipse.technology.equ inox/msg06426.html
 
Read Message
Read Message
Previous Topic:Unable to load Bundle
Next Topic:[p2] Director leaves local update sites in 'Available Software Sites'
Goto Forum:
  


Current Time: Thu Sep 18 03:58:55 GMT 2014

Powered by FUDForum. Page generated in 0.02429 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software