Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Subversive » Help needed, cannot set up an SVN repository
Help needed, cannot set up an SVN repository [message #47130] Mon, 08 June 2009 03:47 Go to previous message
Marc Chamberlin is currently offline Marc Chamberlin
Messages: 27
Registered: July 2009
Junior Member
Ok I admit I am lost.. An since this is my first attempt to set up a
connection from Eclipse to an SVN repository, I guess I am not surprised
either.....

Anywise I will try to recreate the steps I took and perhaps some kind
guru will lead me to the light...

I am using Eclipse/Ganymede or from the Help>About menu it is described as -

Eclipse Platform

Version: 3.4.2
Build id: M20090211-1700

have updated it with all that the built in update tool would provide and
am running under Linux/SuSE11.1

I followed the instructions (as best as I could understand them...) at

http://www.eclipse.org/subversive/documentation/gettingStart ed/aboutSubversive/install.php

and added the site -

http://download.eclipse.org/technology/subversive/0.7/update -site/

to the list of available software sources. From the Subversive Site >
Subversive SVN Team Provider Sources (Incubation) I selected

Subversive SVN Team Provider and the Subversive SVN JDT Ignore
Extensions packages and installed them.

This DID NOT install a group called Subversive SVN Connectors as implied
in the above mentioned instructions but I went back to the internet site
for which I am trying to reach their repository and found an alternate
set of instructions. So I added two more sites in the Software Updates
and Add-ons by first going to the website -

http://www.polarion.com/products/svn/subversive.php?src=ecli pseproject

and from there (I guessed because I am using GANYMEDE Eclipse, so based
on the name...) that I should install the following two site URLs -
http://www.polarion.org/projects/subversive/download/eclipse /2.0/ganymede-site/

http://www.polarion.org/projects/subversive/download/integra tions/ganymede-site/

and then I took another guess and installed everything under the
subgroup called Subversive SVN Connectors. The Subversive Getting
Started instructions are very unclear at this point on what should be
installed but the examples shown imply that one just selects all of the
connectors so I selected the whole group of them.

All of this seemed to go pretty well. So next I attempted to set up an
actual connection to an SVN repository. I am trying to get the source
code for a project called JWebMail and I was also following their
installation instructions found at

http://jwebmail.sourceforge.net/jwebmail-guide.html

Step 5 says - "After Eclipse restarts, use pulldown menu File / Import
and import from Subversion. Enter URL of
https://jwebmail.svn.sourceforge.net/svnroot/jwebmail/trunk and no
other details (unless you're a team developer). If it craps out, restart
Eclipse and retry... or it could be a bad Internet connection to
Sourceforge.

Well it crapped out, I restarted Eclipse several times and always get
the following error messages -

First it complains that The repository location root URL refers to one
of resources configured as a structure node. And it asks me - Do you
wish to normalize URL by cutting its last segment off? Regardless of
whether I answer this Yes or No, or manually remove the /trunk from the
above mentioned URL, I get another error saying that the Validate
Repository Location operation failed with the following hint -

SVN: '0x00400006: Validate Repository Location' operation finished with
error: Selected SVN connector library is not available or cannot be loaded.
If you selected native JavaHL connector, please check if binaries are
available or install and select pure Java Subversion connector from the
plug-in connectors update site.
If connectors already installed then you can change the selected one at:
Window->Preferences->Team->SVN->SVN Client.
Selected SVN connector library is not available or cannot be loaded.
If you selected native JavaHL connector, please check if binaries are
available or install and select pure Java Subversion connector from the
plug-in connectors update site.
If connectors already installed then you can change the selected one at:
Window->Preferences->Team->SVN->SVN Client.

This does not seem to be saying that the repository location is invalid,
rather it is complaining about the Selected SVN connector and tells me
to select one by going to Window->Preferences->Team->SVN->SVN Client. So
I did and yes there appears to be a list selector called SVN Connector
but NOTHING can be selected!

As I said, I am now lost in the dark... Dunno what an SVN connector
really is, how to tell if they got installed properly (appears they
didn't would be my guess), which one I should be using IF I was able to
select one (would have guessed again...) nor what I might have done
wrong....

I tried to uninstall all of these plugins, so as to try an retry from
the beginning, but no matter how I try I get another error message saying -

Cannot find a solution satisfying the following requirements
org.eclipse.swt [3.4.0.v3448f].

So I can neither go forwards, nor backwards.. I am stuck as they say....

Appreciate any help offered, and thanks in advance...


Marc...
 
Read Message
Read Message
Read Message
Read Message
Previous Topic:subversive does not show in prefereces
Next Topic:How do I get Subversive to recognise more CA root certificates?
Goto Forum:
  


Current Time: Thu Sep 18 11:45:31 GMT 2014

Powered by FUDForum. Page generated in 0.02688 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software