Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Archived » Buckminster » "Unable to acquire application service" on Mac OS X
"Unable to acquire application service" on Mac OS X [message #517230] Fri, 26 February 2010 16:10 Go to previous message
Ralf Ebert is currently offline Ralf EbertFriend
Messages: 72
Registered: July 2009
Member
Hi,

I just ran into a little problem when running Buckminster on Mac OS X,
just thought I should post a note about it in case somebody else runs
into this.

When starting Buckminster it failed with this exception in the log:

!SESSION 2010-02-26 16:59:50.552
-----------------------------------------------
eclipse.buildId=unknown
java.version=1.6.0_15
java.vendor=Apple Inc.
BootLoader constants: OS=macosx, ARCH=x86_64, WS=carbon, NL=de_DE
Framework arguments: help
Command-line arguments: help

!ENTRY org.eclipse.osgi 4 0 2010-02-26 16:59:52.200
!MESSAGE Application error
!STACK 1
java.lang.IllegalStateException: Unable to acquire application service.
Ensure that the org.eclipse.core.runtime bundle is resolved and started
(see config.ini).
at
org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher .start(EclipseAppLauncher.java:74)
at

org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseS tarter.java:368)
at
org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseS tarter.java:179)
at

sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAcce ssorImpl.java:39)
at

sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMe thodAccessorImpl.java:25)
at

java.lang.reflect.Method.invoke(Method.java:597)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java: 559)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:514)
at org.eclipse.equinox.launcher.Main.run(Main.java:1311)
at org.eclipse.equinox.launcher.Main.main(Main.java:1287)


I guess the problem is the combination ARCH=x86_64, WS=carbon which was
guessed automatically, when I explicitly specified these when
installing Buckminster this fixed the problem:

../director -r
http://download.eclipse.org/tools/buckminster/headless-3.5/ -d
/Users/ralf/jobs/re_builds/buckminster35/ -p Buckminster -i
org.eclipse.buckminster.cmdline.product -p2.os macosx -p2.ws cocoa
-p2.arch x86_64 -p2.nl en

Greetings,

Ralf


--
http://www.ralfebert.de/blog/
 
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Previous Topic:How to best deal with broken Maven2 meta-data
Next Topic:Can't install headless 3.6
Goto Forum:
  


Current Time: Tue Sep 21 15:19:22 GMT 2021

Powered by FUDForum. Page generated in 0.02055 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top