Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Plugin Development Environment (PDE) » Import Launch Config Hangs Eclipse with 100% processor usage and then runs out of memory(Occurs with Indigo and Juno)
Import Launch Config Hangs Eclipse with 100% processor usage and then runs out of memory [message #1067465] Mon, 08 July 2013 20:05
Mark Leone is currently offline Mark Leone
Messages: 67
Registered: April 2012
Member
I exported a launch configuration with the export wizard, and then tried to import it into another workspace. Eclipse hung for several minutes with processor utilization between 90-100%, and then finally reported that it was out of memory. (Sometimes it reports it's out of heap space, other times it complains about a GC limit being reached.) Increasing Max PermGen or other memory limits only makes it take longer to fail.

This occurred on two different eclipse instances on separate networks, also with three separate launch configs. The Launch configs work properly when used to launch a workbench. The problem originally occurred on Juno, so I tried Indigo, and got the same exact result.

I searched the forums and bugzilla, and can't find any reference to this problem. I'm having a hard time believing such a basic and nasty bug has gone unreported since Indigo, so maybe I'm doing something wrong. But there's really not much involved here. Just export a launch config and try to import it. Anyone else seeing this? Any ideas why this is occurring with multiple eclipse instances and launch configs?

edit: Platforms where I found this error are Centos 6.4 and RHEL 5.8

[Updated on: Tue, 09 July 2013 15:55]

Report message to a moderator

Previous Topic:Extension Point Inspector?
Next Topic:Eclipse Plugin Development (w/PDE)
Goto Forum:
  


Current Time: Wed Sep 03 02:18:58 GMT 2014

Powered by FUDForum. Page generated in 0.03123 seconds