|Re: EMF 2.9 and RAP 1.5 [message #1012695 is a reply to message #1012480]
||Fri, 22 February 2013 03:39
| Ed Merks
Registered: July 2009
I think the changes we made should allow it to continue to work with 1.5
But I'm not sure if Dennis is building against 2.0 or against 1.5
The build inserts the bounds, so it sounds like he's building against
2.0 if that's what you're seeing as the lower bound.
In general, because RAP has broken APIs, you should expect that
frameworks using it will similarly need to make incompatible changes,
although that's not the case for EMF's RAP support.
On 21/02/2013 5:32 PM, Lothar Werzinger wrote:
> I have a RAP 1.5 application and I tried to create a target platform
> based on the latest Kepler milestone to get a newer version of CDO and
> As I don't want to make the transition to RAP 2.0 immediately I
> created the target platform with RAP 1.5 instead of RAP 2.0.
> Everything in my application compiles fine, but when I try to build
> the product it fails, as the EMF RAP plugins
> (org.eclipse.emf.rap.common.ui and org.eclipse.emf.rap.edit.ui) depend
> on RAP 2.0 as the minimum plugin version.
> This dependency is the only thing that prevents me currently from
> using CDO 4.2 and EMF 2.9 with my RAP 1.5 based application.
> Is RAP 2.0 really required as the minimum plugin version or could the
> plugins work with RAP 1.X as well? If the plugins don't need 2.0, can
> the version range be changed, so that one can build RAP 1.5
> Applications with EMF 2.9?
> Thanks in advance!
Powered by FUDForum
. Page generated in 0.01659 seconds