Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse Platform » RCP Update Manager not working due to configuration problems
RCP Update Manager not working due to configuration problems [message #277932] Sun, 19 December 2004 15:51 Go to next message
Eclipse User
Originally posted by: StefanHeinrich.web.de

Hi, We want to use the update manager to keep our rcp application up to
date.
i have packaged our plugins into features and made an update site for
them: http://sooja.dm.fh-furtwangen.de/updatesite/update/
I i try to update from our site within eclipse everything is working fine
but if I try the same inside our RCP i get an error saying something about
configuration problems:

Current configuration contains errors that are not corrected by the
requested operation and more errors would be introduced. See details for
more information.
----- Current configuration problems -----
de.sooja.framework-feature (1.0.1) requires plug-in "org.eclipse.ui".
de.sooja.site.usecase1-feature (1.0.1) requires plug-in
"org.eclipse.ui".
de.sooja.server.web-feature (1.0.0) requires plug-in
"org.eclipse.help.appserver".
----- Configuration problems after the operation -----
de.sooja.site.usecase2-feature (1.0.0) Update conflict detected (see
details). Please deselect this update and try again.
de.sooja.framework-feature (1.0.1) requires plug-in "org.eclipse.ui".
de.sooja.site.usecase1-feature (1.0.1) requires plug-in
"org.eclipse.ui".
de.sooja.server.web-feature (1.0.0) requires plug-in
"org.eclipse.help.appserver".
de.sooja.site.usecase2-feature (1.0.0) requires plug-in
"org.eclipse.ui".

the point is all the plugins marked as required are in fact there in our
rcp plugins directory(!)
please help me, I really have no clue what is causing that error...

Thx, Stefan Heinrich

Sooja Project
(www.sooja.de)
Re: RCP Update Manager not working due to configuration problems [message #277934 is a reply to message #277932] Sun, 19 December 2004 16:03 Go to previous messageGo to next message
Eclipse User
Originally posted by: dorian.birsan.net

check the RCP FAQ, last item.

"Stefan Heinrich" <StefanHeinrich@web.de> wrote in message
news:cq4814$v1g$1@www.eclipse.org...
> Hi, We want to use the update manager to keep our rcp application up to
> date.
> i have packaged our plugins into features and made an update site for
> them: http://sooja.dm.fh-furtwangen.de/updatesite/update/
> I i try to update from our site within eclipse everything is working fine
> but if I try the same inside our RCP i get an error saying something about
> configuration problems:
>
> Current configuration contains errors that are not corrected by the
> requested operation and more errors would be introduced. See details for
> more information.
> ----- Current configuration problems -----
> de.sooja.framework-feature (1.0.1) requires plug-in "org.eclipse.ui".
> de.sooja.site.usecase1-feature (1.0.1) requires plug-in
> "org.eclipse.ui".
> de.sooja.server.web-feature (1.0.0) requires plug-in
> "org.eclipse.help.appserver".
> ----- Configuration problems after the operation -----
> de.sooja.site.usecase2-feature (1.0.0) Update conflict detected (see
> details). Please deselect this update and try again.
> de.sooja.framework-feature (1.0.1) requires plug-in "org.eclipse.ui".
> de.sooja.site.usecase1-feature (1.0.1) requires plug-in
> "org.eclipse.ui".
> de.sooja.server.web-feature (1.0.0) requires plug-in
> "org.eclipse.help.appserver".
> de.sooja.site.usecase2-feature (1.0.0) requires plug-in
> "org.eclipse.ui".
>
> the point is all the plugins marked as required are in fact there in our
> rcp plugins directory(!)
> please help me, I really have no clue what is causing that error...
>
> Thx, Stefan Heinrich
>
> Sooja Project
> (www.sooja.de)
>
Re: RCP Update Manager not working due to configuration problems [message #277936 is a reply to message #277934] Sun, 19 December 2004 16:26 Go to previous message
Eclipse User
Originally posted by: StefanHeinrich.web.de

Thx a lot, you just made my day :)

I've read the FAQ, but couldn't remember that part...

dorian birsan wrote:

> check the RCP FAQ, last item.

> "Stefan Heinrich" <StefanHeinrich@web.de> wrote in message
> news:cq4814$v1g$1@www.eclipse.org...
>> Hi, We want to use the update manager to keep our rcp application up to
>> date.
>> i have packaged our plugins into features and made an update site for
>> them: http://sooja.dm.fh-furtwangen.de/updatesite/update/
>> I i try to update from our site within eclipse everything is working fine
>> but if I try the same inside our RCP i get an error saying something about
>> configuration problems:
>>
>> Current configuration contains errors that are not corrected by the
>> requested operation and more errors would be introduced. See details for
>> more information.
>> ----- Current configuration problems -----
>> de.sooja.framework-feature (1.0.1) requires plug-in "org.eclipse.ui".
>> de.sooja.site.usecase1-feature (1.0.1) requires plug-in
>> "org.eclipse.ui".
>> de.sooja.server.web-feature (1.0.0) requires plug-in
>> "org.eclipse.help.appserver".
>> ----- Configuration problems after the operation -----
>> de.sooja.site.usecase2-feature (1.0.0) Update conflict detected (see
>> details). Please deselect this update and try again.
>> de.sooja.framework-feature (1.0.1) requires plug-in "org.eclipse.ui".
>> de.sooja.site.usecase1-feature (1.0.1) requires plug-in
>> "org.eclipse.ui".
>> de.sooja.server.web-feature (1.0.0) requires plug-in
>> "org.eclipse.help.appserver".
>> de.sooja.site.usecase2-feature (1.0.0) requires plug-in
>> "org.eclipse.ui".
>>
>> the point is all the plugins marked as required are in fact there in our
>> rcp plugins directory(!)
>> please help me, I really have no clue what is causing that error...
>>
>> Thx, Stefan Heinrich
>>
>> Sooja Project
>> (www.sooja.de)
>>
Previous Topic:3.1M4 Problem Crash on Startup
Next Topic:velocity, bundle, resource loading
Goto Forum:
  


Current Time: Fri Sep 19 15:58:51 GMT 2014

Powered by FUDForum. Page generated in 0.01781 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software