Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » Java Development Tools (JDT) » is not accessible due to restriction on required library
is not accessible due to restriction on required library [message #260822] Sat, 27 June 2009 00:04 Go to next message
S Iyengar is currently offline S Iyengar
Messages: 8
Registered: July 2009
Junior Member
I just updated to 3.5 and I get the above error. How do I resolve this
error? I never got this in 3.4 i am using the 64 bit eclipse. I get this
error on both windows and linux. Any help is appreciated.

Thx.
Re: is not accessible due to restriction on required library [message #260830 is a reply to message #260822] Sat, 27 June 2009 07:45 Go to previous messageGo to next message
Dani Megert is currently offline Dani Megert
Messages: 3801
Registered: July 2009
Senior Member
S Iyengar wrote:
> I just updated to 3.5 and I get the above error. How do I resolve this
> error? I never got this in 3.4 i am using the 64 bit eclipse. I get
> this error on both windows and linux. Any help is appreciated.
Well is the error correct or not?

Dani
>
> Thx.
>
>
>
Re: is not accessible due to restriction on required library [message #260837 is a reply to message #260830] Sat, 27 June 2009 10:45 Go to previous messageGo to next message
S Iyengar is currently offline S Iyengar
Messages: 8
Registered: July 2009
Junior Member
Dani,

The JRE has not been modified/updated. It is the same as it was in 3.4.2.
(I never got this error in 3.4.2). I'd never seen this message before.
Frankly, I don't understand what this means. The file attributes for the
jar file is the same as the other Jar's in the jre6/lib/ext. I don't know
if this is correct or not.

All I get is this. If this is correct, How do I change the restrictions?

Access restriction: The field BI from the type SerialPortEvent is not
accessible due to restriction on required library
/opt/jre6/lib/ext/RXTXcomm.jar ComControl.java /emerald/src/com/s5systemsinc/serialio line
107 Java Problem

Thanks,
Re: is not accessible due to restriction on required library [message #260870 is a reply to message #260837] Mon, 29 June 2009 10:10 Go to previous message
S Iyengar is currently offline S Iyengar
Messages: 8
Registered: July 2009
Junior Member
If I add the Jar file as an external jar and move it up before the JRE
system Library (in order of export), I don't get this error.
Previous Topic:JUnit Library broken after upgrade to Eclipse 3.5 (Galileo)
Next Topic:Java Editor shows 'class resolution' errors in Galileo
Goto Forum:
  


Current Time: Thu Oct 23 19:17:53 GMT 2014

Powered by FUDForum. Page generated in 0.02221 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software