Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse Platform » IDocument not found
IDocument not found [message #255266] Thu, 24 June 2004 12:53 Go to next message
Eclipse User
Originally posted by: christian.hauser.dvbern.ch

Hello,

I have a class that uses org.eclipse.jface.text.IDocument. However, the
class does not compile, because IDocument cannot be found.

I added jface.jar, jfacetext.jar and several other JAR files to the
classpath with no success.

Any hint is highly appreciated. I'm using Eclipse 3.0RC3.

Thanks,
Christian
Re: IDocument not found [message #255270 is a reply to message #255266] Thu, 24 June 2004 12:57 Go to previous messageGo to next message
Eclipse User
Originally posted by: christian.hauser.dvbern.ch

Christian Hauser wrote:

> Hello,
>
> I have a class that uses org.eclipse.jface.text.IDocument. However, the
> class does not compile, because IDocument cannot be found.
>
> I added jface.jar, jfacetext.jar and several other JAR files to the
> classpath with no success.

I just found it: org.eclipse.text (text.jar)

--christian
Re: IDocument not found [message #258248 is a reply to message #255270] Sun, 04 July 2004 21:30 Go to previous message
Holger Muegge is currently offline Holger Muegge
Messages: 7
Registered: July 2009
Junior Member
Many people (like me too) seem to have this problem.

Even worse: PDE-Tools --> Update Classpath does not work anymore since I
used IDocumentListener etc. It does not assume that text.jar is needed.

Is this a bug, or do I oversee something?


Thanks,

Holger


Christian Hauser wrote:
> Christian Hauser wrote:
>
>> Hello,
>>
>> I have a class that uses org.eclipse.jface.text.IDocument. However,
>> the class does not compile, because IDocument cannot be found.
>>
>> I added jface.jar, jfacetext.jar and several other JAR files to the
>> classpath with no success.
>
>
> I just found it: org.eclipse.text (text.jar)
>
> --christian
Previous Topic:openEditor Problems With Eclipse 3.0
Next Topic:Porting to 3.0 & Eclipse's complexity
Goto Forum:
  


Current Time: Thu Oct 30 15:18:57 GMT 2014

Powered by FUDForum. Page generated in 0.01818 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software